Turbobricks Forums

Turbobricks Forums (https://forums.tbforums.com/index.php)
-   showroom (https://forums.tbforums.com/forumdisplay.php?f=16)
-   -   Replacing entire fuel system (https://forums.tbforums.com/showthread.php?t=254914)

M.H. Yount 03-16-2012 12:57 PM

Replacing entire fuel system
 
Decided it was time for a change. I'll be putting a Deatschwerks 300 L/Hr in-tank pump in the car and completely re-plumbing the system. The Ford engine has supply/return connections on the front/passenger side of the compartment. So I'm doing away entirely with the Volvo fuel pumps/lines/filter (firewall) -- and replacing it with a system that runs up the passenger side of the car. It'll start with the fabrication of a new tank-top using .0625" aluminum plate. -6AN bulkhead fittings will attach to that -- and from there I'll run Push-Tite series 8000 textile-braided hose to the front for supply and return. I'll mount a Russell 10 micron Profilter up front some place I can easily access to change the paper element. Not in a big hurry - so this one will take a week or two (or three -- I just retired and seem to not be in a hurry for anything). This set up should handle the LS3 I ultimately want to put in the car, and also make room for a pair of mufflers on either side of the car ahead of the rear axle.

Starts by rough cutting the aluminum plate to a 90mm size (a bit more than 3.5"). I'll trim it for a perfect fit once I've removed the existing in-tank pump assembly and can measure more carefully. I went to the Pull-A-Part to see if I could modify a factory tank-top --- but once I saw how the compression ring holds it in -- it was easier to simply cut a piece of aluminum.

http://i937.photobucket.com/albums/a...m/DSC00001.jpg
http://i937.photobucket.com/albums/a...m/DSC00002.jpg

olov 03-16-2012 01:06 PM

very cool, gl, i definitely wanted to clean up my intank setup with better wiring and better hose fittings

M.H. Yount 03-16-2012 01:11 PM

My fittings arrive today and tomorrow (3-16/17) so I should be able to remove the factory in-tank tomorrow. I want to pull it out and take some careful measurements/references before I start drilling holes in the aluminum. I'll be creating a brand new circuit to fire the pump. The Ford ECU has a circuit that provides ground specifically for a fuel pump -- 3 seconds of prime at ignition on unless it sees an alternator field (engine running). Hot out of a new 16A fuse in the fuel pump spot on the box, and a new 10 gauge wire to the back --- all out of a new and more robust relay. Do away with the factory set up altogether.

NONHOG 03-16-2012 01:21 PM

Quote:

Originally Posted by M.H. Yount (Post 4097611)
( I just retired and seem to not be in a hurry for anything)

Good for you! Let the games begin!

M.H. Yount 03-16-2012 05:57 PM

About 90% of what I ordered arrived today....enough to begin taking the existing system off the car this weekend.

http://i937.photobucket.com/albums/a...m/DSC00003.jpg

M.H. Yount 03-17-2012 08:42 AM

Here's a pretty useful hands-on article on messing with the in-tank assembly....

http://cleanflametrap.com/transferPump.htm

M.H. Yount 03-17-2012 07:42 PM

Most of the rest of the fittings arrived today. So -- no reason to put things off any longer. Safety first -- started with flipping the disconnect on the battery. Also realized I'd have some gasoline fumes in the car/garage - so went ahead and turned on all lights, box fan on low and opened window/attic stairs. Wanted to minimize any ignition sources -- so turn everything on first and leave it on.

Started here --

http://i937.photobucket.com/albums/a...m/DSC00004.jpg

Popped the plastic carpet pins and get it out of the way --

http://i937.photobucket.com/albums/a...DSC00005-1.jpg

Remove the plastic cover to get to the electrical connections, and remove the access plate --

http://i937.photobucket.com/albums/a...DSC00006-2.jpg

Doesn't look bad at all given the corrosion I've seen on some of these cars! Cleaned up with a wire brush and a dental pick, shop vac'd all debris up, worked a rag under the supply/return hoses to catch any fuel that might be there when I cut the hoses -- and marked the vent and return lines for a reference when I put things back together (want to be sure the gauge sender is facing the right way.

http://i937.photobucket.com/albums/a...DSC00008-1.jpg

Cut both hoses (virtually no fuel came out) and put IPD's fancy lock ring tool on and give it a 1/8th turn counter-clockwise.....

http://i937.photobucket.com/albums/a...DSC00009-1.jpg

....and without too much fuss, out it comes! The whole thing took about 10 minutes. It's an AC pre-pump and the connecting hose looks new so I'm thinking it's been replace at some point. But not since '96.

http://i937.photobucket.com/albums/a...DSC00010-1.jpg

Then I took my new tank-top (see first pics) and with the old o-ring and retainer I sealed the tank to stop fumes from filling the garage and to keep stuff from finding its way into the tank.

http://i937.photobucket.com/albums/a...DSC00011-1.jpg

I'll take some careful measurements on bottom of pump and sender location and then decided if I want to modify the factory assembly or make a new assembly using the aluminum plate.

M.H. Yount 03-17-2012 11:25 PM

After examining the stock assembly more closely I think I'm going to take a stab at modifying it to accept the new fittings. I believe I can install the new bulkhead fittings in the two holes where the sender wire and the pump hot wire exit the top. I'll use the existing vent line (cut off the bend) as an exit point for the wires. This will allow the sender to stay in place attached to the stock return line - which I'll have to seal at the top. The pump can be bolted to the bottom of that same line in stock fashion. I can cut off and seal the stock supply line. The unit will be grounded in the same way it currently is. We'll see what havoc I can wreak with the cut-off wheel and the Dremel in the morning.

M.H. Yount 03-18-2012 10:03 AM

Partial disassembly of the sender/pump 'assembly'. Removed the pre-pump. I can modify the bracket to accept the Deatschwerks unit. I was able to pry the electrical connections out of the housing. I'll make a new soldered connection to connect the fuel gauge sender to the harness. I simply cut the pump hot wire as new connections will be made for the new pump. There have been issues with bad grounds causing pump challenges/failures -- so I'll run the hot and ground wires out of the tank to be sure I've got a good ground outside the unit. I'll cut the stock supply line off much shorter and use it as a conduit to run my electrical wires out of -- hot, ground and sender. I'll leave the capped vent line as it is and I'll cap the stock return line. In the bottom picture you can see the holes where the electrical connections came through. I'll modify those to accept the -6AN bulkhead fittings for supply and return lines. Time for the baby cutoff wheel...

http://i937.photobucket.com/albums/a...DSC00012-1.jpg

http://i937.photobucket.com/albums/a...DSC00013-1.jpg

M.H. Yount 03-18-2012 10:03 AM

Opened up the backside so I have access to the bulkhead fitting washers and nuts; cut off the stock supply line so I can use it as electrical conduit; opened up the existing electrical connection holes for the bulkhead fittings.

http://i937.photobucket.com/albums/a...m/DSC00014.jpg

Also cleaned up the top -- cutting off stock supply/return ells so I can cap the return line. Have one of the bulkhead fittings test fit in the hole.

http://i937.photobucket.com/albums/a...DSC00016-1.jpg

After I finish up the openings, it looks like if I open up the raised edges ('nubs') of the plastic pump clamp, the pump will go in the stock holder just fine. I'll put a stainless clamp around the pump to create a barrier that keeps the pump from trying to sit/fall any lower. Of course, the hose to the supply line will help hold it in place as well.

M.H. Yount 03-18-2012 06:37 PM

Bulkhead fittings installed and the pump test fit. Thought I could open up the plastic clamp enough to fit the DW pump - but was concerned it was too snug and might suffer a stress related failure over time. So ended up making a small 'slit' in the plastic clamp and putting a stainless clamp around it all. Looks like it's going to work fine.

http://i937.photobucket.com/albums/a...m/DSC00017.jpg

http://i937.photobucket.com/albums/a...DSC00018-1.jpg

http://i937.photobucket.com/albums/a...DSC00019-1.jpg

CAPT_BLOTTO 03-19-2012 01:09 AM

I like where this is going. I bet this isn't cheap though.

M.H. Yount 03-19-2012 08:07 AM

It's only expensive if you can't afford it. :)

idrive_MD 03-19-2012 12:09 PM

sweet deal

M.H. Yount 03-19-2012 03:42 PM

Picked up my $5 40A automotive relay at Radio Shack. And I bit the bullet and bought the SAE30R10 submersible hose for the pump to 3/8" supply line inside the tank. That is one pricey little piece of 1' hose. Also got the SAE30R9 hose rated for EFI systems to make the short connections to the fuel rail barbs up front. This evening I'll try my hand at flaring and bending a small piece of 3/8" aluminum tubing to go between the bulkhead fitting and the pump outlet inside the tank. The piece will only be 4"-5" long -- but it requires some interesting bends in order to keep it as close to the stock return line is possible. I've got to keep everything compact so I can have a hope of getting this beast back through the stock tank opening. I'm also going to take a careful measurement to the bottom of the tank so I can adjust the pump pickup height, the return tube height and the sender float. My gauge reads so it leaves a good 3-4 gallons in the tank when it's showing empty. I can see now how to adjust/fix all that.

BlueSwede 03-20-2012 06:37 AM

Thumbs up!
 
I like....
Kinda backward from most, trying to get rid of intank pump..but would negate vapor lock effect when intank removed and just use under car pump..smart.

Congrats on finding a boat load of time on your hands...looks like it's off to a good start..enjoy..you earned it.

M.H. Yount 03-20-2012 09:04 AM

In-tank is a better mousetrap -- quieter, cooler, never loses prime. There is little downside especially since Volvo saw fit to make it relatively accessible. I'd prefer a LITTLE bigger opening to work with -- but at least this small opening into the tank makes you think about how you route/package things in this pump/sender assembly. The irony is that I'm doing it mainly so I have more exhaust system options....my wife is going to kill me.

I guess I equate vapor lock with low pressure (carbs) and high under-hood temps. While technically a loss of prime is vapor lock, I don't think the term was coined to describe what happens when you can't overcome a gravity issue to get fuel to the suction side of the inline.

Magnum TE 03-20-2012 09:41 AM

Thank you for the detailed pictures and the writeup.

PDX240 03-20-2012 09:48 AM

Nice work and write up, sir. Glad you are molesting 240's for retirement. Continue..

JohnMc 03-20-2012 09:53 AM

Very nice and informative. I've had a DW300 pump sitting around the garage for several months now, I need to get around to putting it in.

M.H. Yount 03-20-2012 05:01 PM

Well - interestinger and interestinger. I knew it would be tight. And it is. Managed to get it in and out WITHOUT the return tube. We'll see what happens with this set up. You have to hold your mouth 3 ways from 'just right' to implant it or remove it. Just an 1/8" larger diameter on the hole would make all the difference. And the frustrating thing is that it's only as small as it is because of the orientation detent --- which you don't need if you know what you're doing. Of course, I'm brainstorming how to remove that and perhaps enlarge the hole. But I can't come up with a way to do that without getting a bunch of debris inside the tank - not to mention, well, fire. Not good. Cross fingers....I'm going to test fire it to be sure the pump works; and test the sender to be sure the gauge is still working before I try to put it in. Because if I can get that danged thing in -- I'll worry about taking it back out later!!

This morning involved measuring tank depth (about 10.75" from bottom of rim to bottom of tank) and then setting the pump/float height, pinching off and soldering shut the unneeded supply and vent lines; routing wires and sealing off what little of the old supply line isn't filled up with wire (gasoline-proof sealant), flaring/bending hard lines on new supply/return, connecting the short hose sections. Every clamp I put on (2 on supply line and 1 on the pump itself) had to be re-oriented to get it in the tank.

http://i937.photobucket.com/albums/a...m/DSC00020.jpg

http://i937.photobucket.com/albums/a...DSC00021-1.jpg

M.H. Yount 03-21-2012 05:39 PM

Well - first attempt = fail. With the hard return pipe in place -- just too big. Finally pulled my head out (of the gas tank....) and actually measured the opening with calipers -- and used those calipers to test my second attempt. Used a piece of 3/8" aluminum, then hose down to a piece of the original supply line. Looked like this....

http://i937.photobucket.com/albums/a...DSC00022-1.jpg

And as you can see from the shot below.....victory. Went in pretty danged easily all things considered. New o-ring and retainer ring from FCP Groton.

http://i937.photobucket.com/albums/a...m/DSC00023.jpg

I believe (careful here...) that the tricky part is over. I now have a DW300 in the tank with -6AN supply and return fittings to hook up to. Now it's simply 1) remove (demolish) the old system; 2) route/secure the new lines; 3) create a new electrical circuit to run it. I tested the fuel gauge/sender with the unit sitting in the trunk. I now know what max full and completely empty looks like on the gauge. One thing is certain --- when the gauge gets close to the red, I need to be seriously looking for fuel. I'll spare you pics of the demolition -- imagine the inline pump/accumulator gone, the fuel lines gone and the firewall mounted filter gone. I will snap a few shots of the filter installation (likely above the rearend on the bulkhead that supports the chassis end of the Panhard rod) and new hose routing.

M.H. Yount 03-22-2012 04:14 PM

Rear harness just about ready to go back in. Used the factory sheath and grommet. Pulled the connector for the hot side of the pump out of the factory plug and took it apart so I could put larger gauge wire from the plug to the pump wiring harness. That's the yellow wire in the picture. I've done this several times. If you're careful you can pry the crimp up on the factory plugs and put larger gauge wires in. I recrimp and then solder the connection - then cover with heat shrink. I added a fourth wire - a separate ground for the pump. Based on feedback further up the thread -- a good ground for the pump is a must. So I ran an additional wire (black) that will directly ground the pump to the battery. The brown wire is the factory ground -- still use it to ground the assembly so the sender works. Yellow wire is hot for the pump. And the black sleeve/gray wire is the sender unit.

http://i937.photobucket.com/albums/a...m/DSC00024.jpg

M.H. Yount 03-27-2012 09:16 PM

A couple of posts up the page you can see where the new plumbing will start - at the tank. Below is where we're running to -- kind of underneath the 5.0's alternator on the passenger side.

http://i937.photobucket.com/albums/a...DSC00025-1.jpg

And here's the result of the demolition today - Volvo 240 fuel system de-constructed. I left the metal clamps in place that held the factory supply line. May be able to modify the rubber 'biscuits' and use those and the clamps to hold the new return line. Run the supply line up the other driver's side of the car. We'll see what it looks like when I get under there.

http://i937.photobucket.com/albums/a...DSC00027-1.jpg

Miracle of miracles -- no gasoline spilled on the floor!!! Some observations - first, it's damned difficult to get the hard fuel lines off without a lift and without a bunch of other stuff out of the way. As in the car almost torn down and on a rotisserie... Luckily I knew I wasn't re-using any of it -- so the tubing cutter was a miracle worker. Second -- I'm amazed at the shape the rubber bits were in at the back of the car. 30-year old rubber tubing is not supposed to look that good... Third -- the SAE30R7 hose I used to connect the return line near the Volvo filter (firewall) to the fuel rail was in TERRIBLE shape. 10 years old and it's a miracle that it hadn't started leaking it was cracked so bad in some places. In fact, when I tried to remove it from the barbed fitting you see in the picture above - the outer rubber delaminated from the textile reinforcement. Saving grace was only that the return is under very little pressure. Just a psi or two above atmospheric. Won't be using that again. The SAE30R9 hose I used on the high pressure supply side held up just great. So -- if you're plumbing the system to last I recommend the SAE30R9 spec for both supply and return. Fourth -- removing the filter from the firewall left a gaping ugly mess. Gotta figure out how to hide that behind.....something.

M.H. Yount 03-29-2012 07:36 PM

A little more progress today. Got the filter mounted -- and I believe I figured out how I want to route the new supply and return lines. The filter is a 12" Russell 10 micron filter with replaceable filter element.

I removed the metal support between the front of the fuel tank and the unibody. I used a piece of angle to mount the filter to the backside of this bracket. It puts the filter very near the top of the fuel tank. The supply line to the filter will be less than 6" long. Hard to photograph without the car on a lift -- here's a couple of shots to give you an idea. The first is just the filter on the bracket, the next two mounted in the car. I wanted to find a location up front that provided a bit easier access. But I felt any locations that on the route from rear to front left the filter to exposed. The only reasonable location was in front of the passenger side front tire up under the fender. But a minor accident could turn major pretty quickly if a fuel line ruptured. This location is about as safe as it gets.

http://i937.photobucket.com/albums/a...DSC00029-1.jpg

http://i937.photobucket.com/albums/a...DSC00030-1.jpg

http://i937.photobucket.com/albums/a...DSC00031-1.jpg

The supply line will exit the filter on the passenger side and I'll route it with new insulated hangers along the same path that the stock lines take up the driver's side. The return line will use the same factory insulators that the original supply line used. There are 5 metal clamps that simply bend out of the way -- and rubber donuts can be removed. The original supply line sat inside of these.

http://i937.photobucket.com/albums/a...DSC00032-1.jpg

I found I could easily cut away most of the internal section of the insulator so it looks like this:

http://i937.photobucket.com/albums/a...DSC00033-1.jpg

With it opened up the new series 8000 push-tite line in -6AN fits inside as if it were made to. I'll put it right back in the stock supply line location.

http://i937.photobucket.com/albums/a...DSC00034-1.jpg

More to come. This filter location is going to require 2 more fittings which I ordered from Summit today. These are 90 degree fittings - one side is -6AN female to connect to the filter, the other is barbed to accept the Push-Tite hose. One end of the filter will then be pointed right at the -6AN fitting on top of the pump-plate; the other will be pointed towards the front of the car. $17 - a piece from Summit. Yuck. But it's the right thing to do - vs. trying to 'bend' the hose tightly on both ends of the filter. Not good.


All times are GMT -4. The time now is 01:17 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.