View Single Post
Old 10-15-2013, 08:08 PM   #48
AdmiralSenn
Board Member
 
Join Date: Jan 2007
Location: Vero Beach
Default

I'll check the resistance on the CT sensor this week and see what happens. I do have a fancy Volvo OEM replacement on the shelf just in case, but I don't have an intake manifold gasket handy, will have to acquire one before I try to replace it.

Wastegate actuator is defintiely slightly too preloaded, this is on my list of things to deal with. I picked up an extra 3 pounds of boost. Just haven't had enough time between drives for the motor to cool off, and this weekend I was fighting a sinus thing and didn't even leave the house. When it picks up power it's pretty early, when it gets hot and stops boosting I don't feel the initial power onset until ~3500-4000.

Fairly sure the exhaust side isn't leaking, I haven't seen or heard any symptoms of an exhaust leak. I will check the turbo mounting studs on the manifold though.

I will have to do another intake leak test and make sure there isn't any air going anywhere it shouldn't. If there is one it's likely going to be in the turbo itself, probably the seal you describe. If that's the case I'll just have to live with the reduced performance until I can afford a replacement - I'm not going to risk the downtime on the car to rebuild the turbo if I can swap in a known good replacement and get more power out of it at the same time. Not sure what my options are for a water cooled T3 or T3/T4 that I could ever afford, though.

I'll update when I find something.
AdmiralSenn is offline   Reply With Quote