home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > performance & suspension

Reply
 
Thread Tools Display Modes
Old 05-06-2012, 09:12 PM   #1
PEGASUS 6
Board Member
 
PEGASUS 6's Avatar
 
Join Date: Sep 2009
Location: Building 7
Default 14point7 SLC Wideband O2

Any one running one?

I just got mine, a Pure Plus II. I have a rattle in my newly done exhaust so Im bringing this to the shop with me to get the O2 bung welded in.

What am I looking at here for a basic install? How did you wire it>?

I am going on a road trip soon and this car needs to be capable, I just want to be able to read my AFRs Ill look into the other features of this O2 later.

Thanks!!!
PEGASUS 6 is offline   Reply With Quote
Old 05-06-2012, 10:21 PM   #2
MrBill
fige=500Dollar Mistake
 
MrBill's Avatar
 
Join Date: Jan 2006
Location: Southern Maryland
Default

I have the original one - and it's pretty damn good.

What is your setup?
Wiring it can be as easy as providing switched +12v. If you replace the stock o2 sensor (and are still using some EMS that uses NB o2) you can wire an output to the ECU and have the WB output a NB output to the ECU.
__________________
Quote:
Originally Posted by grnmachine02 View Post
Someone say crazy rays?
1978 244dl - Down for paint/16vt
84 244 - Wilbur - Lemons hopeful
97 960 - New DD/beater
93 245 - Will be cool one day.
10 v50 - Unobtainium T5 R-Design AWD M66
MrBill is offline   Reply With Quote
Old 05-06-2012, 11:21 PM   #3
donalson
Board Member
 
donalson's Avatar
 
Join Date: Aug 2003
Location: Webster, TX (outside houston)
Default

i've got the SLC DIY2... haven't built it yet but once you dig out the documentation it's fairly straight forward (after building up a megasquirt)...

wiring is straight forward... figuring out where it is on 14point7's web page is the hardest part to it... it's under http://14point7.com/Support.php on the UAFC (includes documentation) link...
__________________
Project [S]wede-10... volvo powered S-10?

'91 945ti (new family hauler) - 16t | Hi-tuning MBC | TLAO fuel chip | Hi-Tuning ignition chip | Browntops | 3" AMM | DIY CAI | Mallory coil | cravingboost plug wires | PBR metal master front pads | needs a cam and exhaust
donalson is offline   Reply With Quote
Old 05-07-2012, 04:40 PM   #4
PEGASUS 6
Board Member
 
PEGASUS 6's Avatar
 
Join Date: Sep 2009
Location: Building 7
Default

Im running 1990 B230FT, 960 Throttle body, 3in cold side pipe, 16T hot side polished, 3" DP to 2.5, high flow magna flow cat, Borla straight through rear exit. Nxs MBC, NGK plugs, TLAO chips, 563 Gold Box, Polished 90+ mani, and looking to add a Wide Band!!!
PEGASUS 6 is offline   Reply With Quote
Old 05-07-2012, 04:49 PM   #5
PEGASUS 6
Board Member
 
PEGASUS 6's Avatar
 
Join Date: Sep 2009
Location: Building 7
Default

1 Red System Power Switched 12[v] through 250ma Fuse Use fuseholder +
250ma Fuse
2 Black System Ground If you have a device connected to the
Linear Output, ground this point where the
device is grounded. Otherwise ground to
where ECU is grounded
3 Green LSU Heater Power Switched 12[v] through 5A Fuse Use fuseholder + 5A
Fuse
4 White LSU Heater Ground Ground to engine block or chassis
PEGASUS 6 is offline   Reply With Quote
Old 05-09-2012, 08:40 PM   #6
PEGASUS 6
Board Member
 
PEGASUS 6's Avatar
 
Join Date: Sep 2009
Location: Building 7
Default

so what did you splice into for your 12v source?
PEGASUS 6 is offline   Reply With Quote
Old 05-10-2012, 02:24 PM   #7
klr142
Turbo, what?
 
klr142's Avatar
 
Join Date: May 2004
Location: OR
Default

I should've ordered one of these months ago... I'm doing it now and am wondering if I should grab their MAP sensor or if there's something else out there that's even cheaper and doesn't come with any of the extra stuff(tubing, T, etc.). Is there an even cheaper, and quality option?
klr142 is offline   Reply With Quote
Old 05-10-2012, 02:39 PM   #8
lardzilla
Board Member
 
Join Date: Dec 2010
Location: Kansas City, MO
Default

I've got one too. They say have different power/ground points for the wb o2 sensor and the SLC.

Mine works great, I've installed a netbook where my gauges were and use that for a dashboard.

I am having trouble with RPM input though, negative side of coil and at the tach are no good. Documentation says to tap off the - side of the injectors... any ideas?
__________________
1991 745t "sveedvvagon" s90 front clip, RSI stage I cam, 15g hogged out, ported 90+, 92+ 940 radiator/ic, welded diff, prelude seats... 12.7 1/4mile
1991 244 "ron burgundy" 76 front clip, workin on lt1 swap. soon to be, tow bitch.
1991 744t -> Crushed
2003 BMW E46 330xi 6speed: DD/Snowmobile

Looking for the usual Holset and 16v head...
lardzilla is offline   Reply With Quote
Old 05-10-2012, 03:00 PM   #9
klr142
Turbo, what?
 
klr142's Avatar
 
Join Date: May 2004
Location: OR
Default

Quote:
Originally Posted by lardzilla View Post
I've got one too. They say have different power/ground points for the wb o2 sensor and the SLC.

Mine works great, I've installed a netbook where my gauges were and use that for a dashboard.

I am having trouble with RPM input though, negative side of coil and at the tach are no good. Documentation says to tap off the - side of the injectors... any ideas?
Ground it on the intake manifold with the injector grounds?

Do you have different power/ground points for the sensor and SLC?

I also kind of want to use the round gauge in my dash instead of having the standard rectangular box mounted somewhere random. That way it's less intrusive. Meh, more money!
klr142 is offline   Reply With Quote
Old 05-10-2012, 03:54 PM   #10
donalson
Board Member
 
donalson's Avatar
 
Join Date: Aug 2003
Location: Webster, TX (outside houston)
Default

Quote:
Originally Posted by klr142 View Post
I should've ordered one of these months ago... I'm doing it now and am wondering if I should grab their MAP sensor or if there's something else out there that's even cheaper and doesn't come with any of the extra stuff(tubing, T, etc.). Is there an even cheaper, and quality option?

get it seutp and do a review of it and they'll give you a MAP sensor... it's what i'd go with... the other sensors are much cheaper elsewhere

Quote:
Give us 10 minutes to post a honest 200+ word review of our product, within 60 days of purchase, on any automotive performance forum, email the review to toalan@14Point7.com and receive your choice of bonus. If product was not directly purchased from 14Point7, review must include name of retailer where product was purchased.
donalson is offline   Reply With Quote
Old 05-10-2012, 04:02 PM   #11
klr142
Turbo, what?
 
klr142's Avatar
 
Join Date: May 2004
Location: OR
Default

OOH!^^ Nice! I will definitely be doing that. Thanks for the heads up.

Then, to decide if I really need to keep an eye on the wideband or just put it down in the storage box and get a map sensor for easy logging...

ORDERED!
klr142 is offline   Reply With Quote
Old 05-10-2012, 04:02 PM   #12
donalson
Board Member
 
donalson's Avatar
 
Join Date: Aug 2003
Location: Webster, TX (outside houston)
Default

ya looks like they added the 60 day portion since I bought mine... sucks because I don't qualify now... oh well
donalson is offline   Reply With Quote
Old 05-10-2012, 04:51 PM   #13
PEGASUS 6
Board Member
 
PEGASUS 6's Avatar
 
Join Date: Sep 2009
Location: Building 7
Default

the harness im looking at has a red, white, black, green and brown.

1. what switchable 12v did you line into?
PEGASUS 6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:01 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.