home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

Reply
 
Thread Tools Display Modes
Old 06-18-2019, 10:12 PM   #301
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Finally got a 4 point roll bar put in the car. Not really gonna fit in any classes or anything I don't think or but it should keep 95% of the tracks happy seeing something in there at least. Family and friends were very happy too lol.





Also took the boss out for a ride lol. Got the tires nice and stick after a couple good highway pulls.


And heres just another gratuitous idle walk around video... because I like the way it sounds lol
__________________

Current setup - Aluminum L33/Summit Turbo Stage 2/Gen 1 Billet 7875, single Walbro 450 and Dual AEM 400's, Bosch 210's
60' 1.51 - 1/8 6.38 @ 110.8mph - 1/4 xxx
3060lb no driver
3240lb with driver

Last edited by Andrewhans; 06-18-2019 at 10:19 PM..
Andrewhans is offline   Reply With Quote
Old 06-18-2019, 10:16 PM   #302
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Quote:
Originally Posted by DrHutch View Post
Sounds absolutely amazing bro. Maybe I've worked with only trash people in the past but your Trans guy was pretty quick on tackling that haha.

I've lived in this city on and off for 11 years and I still haven't gone to Coastal yet and my house is no more than 10 minutes away, just never been around long enough to finish a build to bring out there.

Next time you head out to any of the tracks let me know, I would love to see this thing move.
Ill be at Fayetteville this Saturday in the afternoon most likely. 6ish I'd like to get there.
Andrewhans is offline   Reply With Quote
Old 06-22-2019, 01:31 PM   #303
DrHutch
Board Member
 
Join Date: Jul 2015
Location: Jacksonville, NC
Default

Quote:
Originally Posted by Andrewhans View Post
Ill be at Fayetteville this Saturday in the afternoon most likely. 6ish I'd like to get there.
Damn. I'm on duty today.
DrHutch is offline   Reply With Quote
Old 06-23-2019, 07:39 AM   #304
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Quote:
Originally Posted by DrHutch View Post
Damn. I'm on duty today.
Don't worry, you didn'g miss much.

Made a single pass. Engine completely let go at the 1000' mark from the fuel pump halfway dying. Made full boost passes the night prior and everything worked great.

Zero compression when turning engine over. Gonna pull heads today and go from there. I dont see oil everywhere so the block/pan might be good. We'll see!
Andrewhans is offline   Reply With Quote
Old 08-08-2019, 06:45 AM   #305
DrHutch
Board Member
 
Join Date: Jul 2015
Location: Jacksonville, NC
Default

That's horrible, sorry to hear that bro.
DrHutch is offline   Reply With Quote
Old 10-06-2019, 05:00 PM   #306
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Ok... so quick update. Block, camshaft and turbo was NOT ok. Ended up bending 4 gen 4 rods, melting one piston and completely destroying one as well. Cam was hit multiple times from the piston pieces hitting it. Turbo was ruined as well from engine fragments going through it







This was the first hint that the turbo may not be ok...


More posts coming up. Gonna try and update in stages of discovery/repair up to the point I am at today.

Last edited by Andrewhans; 10-06-2019 at 08:08 PM..
Andrewhans is offline   Reply With Quote
Old 10-06-2019, 05:15 PM   #307
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

So I was pretty bummed out and took a solid break from cars for a bit bc of only making one pass and having such a massive failure.

Well I got off my ass and out of my feelings and decided to rebuild, strengthening the weak areas of my last two setups... the fueling.

Since the last engine failed because of a fuel pump getting weak I decided to go "all out" out on the fuel system this time around. I didn't want to deal with trying to hang more pumps inside the tank. So I decided on a sump with a pair of dual -10 feeds going to AEM 400's that then go into a Y that then tie into the rest of the fuel system.

I have a single Walbro 450 in tank and the dual AEM 400's that are triggered at 4psi.




From the tank all the pumps Y together into a -8 line that goes to and through the yard and farm fuel filter that has worked excellent so far for me. I switched to a WIX filter because I like WIX filters a lot. No other reason really.



From the filter it then goes to the engine bay and new fuel rails and fuel pressure regulator.




Still datalogging fuel pressure as it's one of my favorite things to watch and make sure is good.


To help keep the fuel pressure rock solid I went way overkill on the relay and wiring for these extra pumps. 4awg wire direct from battery to an 80amp battery isolator. From the isolator there is one 8awg wire for each pump. Each pump also has a dedicated 8awg ground wire as well.


I also finally stepped up from the little deka 80's and am now running Bosch 210lb injectors. Idle is rock solid and .5-.6 duty cycle lol These injectors works great and I would recommend them to anyone looking for big power.

Last edited by Andrewhans; 10-06-2019 at 08:10 PM..
Andrewhans is offline   Reply With Quote
Old 10-06-2019, 05:35 PM   #308
DrHutch
Board Member
 
Join Date: Jul 2015
Location: Jacksonville, NC
Default

Glad to see you back at it. Sucks that most of your setup got wrecked, but the fuel system is looking solid.
DrHutch is offline   Reply With Quote
Old 10-06-2019, 05:37 PM   #309
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Decided to make a few small upgrades around the rest of the car too. I really like AvE and enjoy his stickers so I purchased a few more from his recent run lol Added a 4" intake tube to pull air directly from the fender


Also FINALLY verified timing on the car. The engine was 6 deg off. So when I was commanding 14deg the engine was actually seeing about 19 or 20 degrees under boost. This explains why Im still chasing the mph I had on the old gen 3 4.8 cast 7875 setup lol Turns out the old timing was SUPER aggressive. Surprised it lasted as long as it did.


Trying to reduce under hood temps a little here.

Andrewhans is offline   Reply With Quote
Old 10-06-2019, 05:43 PM   #310
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

So the video from before leads to the damage you see here to the turbo.
Clue number 2 the turbo may have gotten some damage


The final verdict lol RIP cast 7875 turbo. It was a beast and did great through all of my tuning mistakes and surviving all kinds of abuse. Turbo still spun beautifully with zero shaft play.


Billet 7875 center section installed into the old exhaust and compressor housing. $250 drop in for an extra 100whp over the cast unit.


Here's how all those ugly flux core welds are holding up. They may be ugly but damn they are strong as ****.




Also just encase you were curious the post turbo pre intercooler bend I built that ended up going 141 in the quarter looks like lol



And new sticker I always look at. Helps keep my head straight on the street lol

Last edited by Andrewhans; 10-06-2019 at 08:20 PM..
Andrewhans is offline   Reply With Quote
Old 10-06-2019, 05:44 PM   #311
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Quote:
Originally Posted by DrHutch View Post
Glad to see you back at it. Sucks that most of your setup got wrecked, but the fuel system is looking solid.
Yeah me too. I just needed to take a step back I think.
Andrewhans is offline   Reply With Quote
Old 10-06-2019, 05:52 PM   #312
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Alright! Onto the next victim... oops... I mean engine.

06 L33 engine with 224k miles on it. Has all the goodies. 24x crank trigger but has the really good 799 heads and the very strong gen 4 piston and rods. Plus its an aluminum block so I was able to shave a little over 100lbs off the front of the car.

Pulled the heads off and pulled one piston and rod, checked ring gap and I want to say it was around .026 or so so I stuffed it back together with new head gaskets.




Post install weight. Small 4 point cage, fullsize battery up front, full tank of fuel, me in the drivers seat, wheels and tires I will race on too, only thing I'm missing is the back seat because the car never came with one when I purchased it.
Andrewhans is offline   Reply With Quote
Old 10-06-2019, 06:01 PM   #313
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Now we pretty much caught up.

I love the new cam on this "high" 9.9:1 engine. Summit Turbo Stage 2 sounds great and gives me better idle vacuum, better lowend, midrange and has a beast topend. Pretty much a better cam in every way.


Pretty much tapped out on boost with my current wastegate spring just like before. I've been able to spike to 24psi and hold 22 to redline. Going to switch to a 4port solenoid to keep a soft spring in it for first gear but be able to really add the boost up top and get some "serious" mph out of the setup hopefully.


If you were wondering what trans fluid is in the th350 it's just the cheap-o Oriellys tractor hydraulic fluid. Works amazing and the clutches in this trans are absolutely taking a beating and not slipping at all. Simply blown away at how good this trans/fluid/clutch combo is doing. And yes I buy it in a 5gal bucket for around $50. Makes it easy/cheap to do frequent fluid changes to help the trans stay alive


Here is a nice side shot of the car in its current state with aluminum block, standard size battery, cheap struts($18 for the pair), factory 240k springs, new upper strut mounts and 15A strut beef up plates. I love how the car sits right now. The 235's fit nicely and I car pretty much drive the car like a normal Volvo. The aluminum block REALLY makes it drives a lot better than the iron block.

Last edited by Andrewhans; 10-10-2019 at 09:15 AM..
Andrewhans is offline   Reply With Quote
Old 10-06-2019, 06:07 PM   #314
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

And finally... results

Went to the 1/8th mile a few times and was able to hit some very impressive 60' for a stock suspension 235 drag radial car. Very very happy with how it's doing right now. Hit a new personal best of 6.3 @ 110mph with a 1.51 60'


Here's a couple videos of decent launches. On the first one it actually carried the wheel about 20ft. The second one is another 1.5x 60'




Unfortunately by the end of the night the factory 160k mile explorer LSD clutches had finally had enough and I was basically doing one wheel burnouts and just not putting the power down how I should be. Don't worry Carbon Fiber clutch upgrade is already here and just waiting for me to swap them out. Car still drives fine which makes it tough to tear it down to make changes.


I genuinely think a 1.4x 60' is possible. Maybe even a 5 in the 1/8th with a perfect launch(low 1.4 60') and some more boost and timing thrown at it with this cooler weather coming into the area.

Last edited by Andrewhans; 10-06-2019 at 06:23 PM..
Andrewhans is offline   Reply With Quote
Old 10-06-2019, 10:53 PM   #315
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

Nice recovery! That oil pan full of broken bits pic is impressive, I have never seen that much stuff in a pan before...Sounds great tho and glad it lives to kick ass another day.
__________________
Feedback thread https://forums.tbforums.com/showthread.php?t=144924

1978 242, getting prepped for LS
1979 242, MS, R brakes
2006 V50 T5 AWD @ 17 PSI
2turbotoys is offline   Reply With Quote
Old 10-07-2019, 04:16 PM   #316
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Oh yeah. I love this stupid car.

Currently fighting with ignition cut out around 22-23psi of boost. Pretty sure I'm just blowning the spark out. I think I have the plugs gapped around .025 so I have a LOT of gap left to tighten up.
Andrewhans is offline   Reply With Quote
Old 10-09-2019, 09:50 AM   #317
linuxman51
BRANDSCHUTZVORSCHRIFTEN!
 
linuxman51's Avatar
 
Join Date: Dec 2002
Location: mont, AL
Default

I too am shocked and amazed the th350 is hanging around, knowing what I know about (and have done to) them. but that's good!
__________________
"They bum rushed them in their own crib, they drank all their beer, they partied with their ladies and they left with the trophy"

Now with in-house Dyno tuning!

Megasquirt Tuning!
Plug and play LH 2.4 Megasquirt, now with stealth mode!
linuxman51 is offline   Reply With Quote
Old 10-10-2019, 09:11 AM   #318
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Quote:
Originally Posted by linuxman51 View Post
I too am shocked and amazed the th350 is hanging around, knowing what I know about (and have done to) them. but that's good!
Yeah its a very basic rebuild. Only things that have been changed was a 36element sprag and hardened race. When I broke the sprag and had it tore down my rebuilder said the clutches looked excellent and didnt even replace them lol. That was after a year of abuse. Still going strong after 6 more month of driving. Im not sure if it the fluid/clutch/valvebody cal that he did on it but it is working amazing and holding great power.

I thought I would have destroyed this thing by now but I'm estimating 650whp right now
Andrewhans is offline   Reply With Quote
Old 10-20-2019, 09:23 AM   #319
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

No real update unfortunately. Just been out putting fuel and boost through it. When I ran the 6.3 I was around 19-20psi on the gen 1 billet 7875 and 11-12 deg timing. After some more street tuning and VE table cleanup I'm holding a steady 21-22psi throughout the rpm range and running around 15deg. Hopefully I can knock another .2 or .3 off the ET in the 1/8th. After driving it and turning power up I really do think it has a 9.5 @ 145+ in it as it sits with a decent 1.5ish launch. I know for a fact that it's on a 9 sec tuneup right now lol

Put nearly 100miles on it yesterday bc the weather was amazing and I had a bunch of errands to run and different places to go around town.

Was cruising on the backroads around 50 and saw my buddy outside his house so I gave him a nice back to the future style rolling burnout lol. I ****ing love this stupid car when it's running great like this. Side note: the 235 drag radials may need to be replaced soon haha

Last edited by Andrewhans; 10-20-2019 at 09:31 AM..
Andrewhans is offline   Reply With Quote
Old 10-20-2019, 09:30 AM   #320
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Quote:
Originally Posted by 2turbotoys View Post
Nice recovery! That oil pan full of broken bits pic is impressive, I have never seen that much stuff in a pan before...Sounds great tho and glad it lives to kick ass another day.
Thanks man. It seems so far when I hurt an engine it's just easier to throw the whole thing in the trash and start over honestly lol.

I love the new cam. It's been a big improvement over the sloppy stage 2. The SS2 had a better idle sound but this one out performs it in every way honestly.
Andrewhans is offline   Reply With Quote
Old 10-29-2019, 10:41 AM   #321
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

And the sum bitch blew up again lol. I made the mistake of cleaning the car, changing the oil and prepping the car for a track outting at Fayetteville again. Gonna put up pics soon.

Frustrating part is that I didn't change ANYTHING from the tune that I drive the car everyday. I put almost 1200miles on the engine last month alone beating the daylights out of it with big highway pulls, rolling burnouts and just having a good time. Take it to the track and the first pass off the trailer it goes 10.1@136mph while pedalling twice. The topend felt very weak and after reviewing the datalog I see I was pulling about 3.5 deg of timing due to MAT. Oil pressure was rock solid and perfect. I actually happened to glance at oil pressure in the middle of 3rd gear and was holding steady around 60psi.

Target timing was 14.5 but bc of air temps the engine was seeing only 11deg. 210deg air temps at the top of 3rd, 11.6-11.8 AFR, 21psi boost, 73% content rating. I'm leaning towards a combo of hot air, choked exhaust side and the d585 coils possibly starting to auto discharge. I should have held on to my last set of coils that worked without issue. This set came with the L33 and had almost 140k less miles on it so I figured they would be better to use.

I'm not blaming them but I am suspect of those coils. A good buddy of mine is going to send me a set of "dumb" coils to try and eliminate the chance of it happening again, if that was in fact happening, it's worth the effort to me for sure considering it's a free swap. I'm sending him my d585 coils to use on his wifes budget 4.8 s10. I'm also going to send off my injectors to Erik Derr to get flow tested and cleaned since they have now survived 2 engine failures.

Also have another engine on the way. Managed to find an 08 4.8 non VVT non DOD engine with 209k miles. Gonna leave the rest of the setup the same and step down in cubic inch to hopefully let the turbo work better. I loved my first 4.8 and am going to be excited to run another one.

Figured I'd update you all again lol. Doesn't seem to be many people watching though haha

Last edited by Andrewhans; 10-29-2019 at 11:50 AM..
Andrewhans is offline   Reply With Quote
Old 10-29-2019, 01:30 PM   #322
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Hole in the block. Found this within about 5 min of it being on the trailer.


A piston should be here


Plug readings. E85, 11.6-11.8, timing was 14.5 deg but bc of high air temps 3.5 deg got pulled(210 deg at top of pull), 73% E content


Wrist pin boss ripped out of piston


Motor out and on stand, about 3hrs of work to get here
Andrewhans is offline   Reply With Quote
Old 10-29-2019, 01:57 PM   #323
linuxman51
BRANDSCHUTZVORSCHRIFTEN!
 
linuxman51's Avatar
 
Join Date: Dec 2002
Location: mont, AL
Default

shoot, we watchin'.

so what intercooler core you gonna go with? what are you running right now?
linuxman51 is offline   Reply With Quote
Old 10-29-2019, 02:08 PM   #324
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Quote:
Originally Posted by linuxman51 View Post
shoot, we watchin'.

so what intercooler core you gonna go with? what are you running right now?
Currently running the vs racing 12x31x3. I think it's a 600hp core. I am WAY past the limits of the intercooler in all honesty. Based on boost, timing and air temps I think I was north of 750whp while on the highway and airtemps were cool, 22psi, 15deg, 11.7AFR. Currently there aren't funds for anything besides getting the car up and running again. I will force myself to keep the temps down by manageing the boost target. Probly going to set it and forget it at 18psi or so and just leave it alone.

I'm leaving the country for a minimum of 1 year starting in March and need the car driving and reliable so I don't need to worry about the shop that is going to be storing it for me.

While I'm gone though I will probly have them redesign the intercooler and fit a treadstone TR1245 intercooler in there. I may also have them adapt a gen 2 billet 7875 from VS Racing on there as well. The rest of the system I'm pretty happy with. It's a very responsive street setup.

Last edited by Andrewhans; 10-29-2019 at 02:32 PM..
Andrewhans is offline   Reply With Quote
Old 10-29-2019, 02:26 PM   #325
JohnMc
PV Abuser
 
JohnMc's Avatar
 
Join Date: May 2004
Location: St. Louis
Default

Yikes. That reminds me, I need to figure out why my Goldbox MAT sensor always says exactly 70 degrees.
__________________
'63 PV Rat Rod
'93 245 16VT Classic #1141
JohnMc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:30 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.