home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 03-11-2019, 01:37 PM   #1
Grizzly240
Newbie
 
Join Date: May 2018
Location: Houston tx
Default sound system help alternator issue

hello all i own a 1986 245 love it to death i am running a system in the car 2 jlw0 12s and i plan on going 2 jlw3s but the highest amp alternator i can find is 100amp which is what i put is and thats not enough for what i want to do i dont want to run 2 alternators unless i have to is there any 140 amp to 170 amp alternators i can get im not looking to go to comps or run 2 batteries any suggestions
Grizzly240 is offline   Reply With Quote
Old 03-11-2019, 01:42 PM   #2
DMFWallace
Ignoramus Bigotus
 
Join Date: May 2004
Location: Fredericksburg, VA
Default

Google it:
Clicky
__________________
'90 244 - Too many memories to crush
'92 944T - Need any 940 parts?
'96 854 GLT - Not mine any more but still in the family
'92 245 - For Sale?
'97 854R - Waiting to get fixed
'06 XC90 V8 - Family Hauler - Wifemobile
'04 XC70 - Impulse buy of the year
Feedback:http://forums.turbobricks.com/showth...ght=dmfwallace

Last edited by DMFWallace; 03-11-2019 at 01:55 PM..
DMFWallace is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:18 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.