home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 09-28-2018, 06:27 PM   #26
ZVOLV
<Master Tech>
 
ZVOLV's Avatar
 
Join Date: Nov 2002
Location: California
Default

So does this car start, or not? I can't understand....
__________________
No Start Thread
ZVOLV is offline   Reply With Quote
Old 09-28-2018, 06:58 PM   #27
arjunsw
Newbie
 
Join Date: May 2017
Location: CA
Default

No not yet, im fairly certain its bad fuel pumps. It worked off starting fluid, so i looked more into the fuel system. The fuel pump relay energizes when i crank, so its not burnt. The main fuel pump is getting 12 V even when I bypass the fuel relay, but it only spins once I tap it with a rubber mallet. If I tap it with a rubber mallet, get it spinning for a bit, and crank, it'll start up fine, but will stall after a couple seconds once the pump stops spinning again. I also couldn't hear the in-tank pump when i put my ear in the gas filler neck.

The fuel pump connections were also falling apart in my hands, so i dont thinks it been changed recently, possibly ever.
arjunsw is offline   Reply With Quote
Old 10-05-2018, 09:46 PM   #28
Bready
board deviant
 
Bready's Avatar
 
Join Date: Nov 2002
Default

Replace fuel pump fuse - regardless of what it looks like - and clean the terminals.

At least half of 240 no starts are the result of that fuse.

Costs nothing and it saves you the hassle of the rest of the stuff if that was the issue.
__________________
Quote:
Originally Posted by Pennybridge Pioneer View Post
Just because you didn't experience something growing up doesn't mean other people didn't. Case in point: I can't remember ever being a total moron, but that doesn't mean you aren't one.
Quote:
Originally Posted by ErikS View Post
Eat the dog, shove the gold up my ass, and move to Canada.
Quote:
Originally Posted by Turbo Joe View Post
Keep your minds out of my pants.
http://math.350.org/ http://www.rollingstone.com/politics...-math-20120719 MUST READ!

Kalazdar - (3/23/83 to 5/12/03)
Bready is offline   Reply With Quote
Old 10-05-2018, 09:47 PM   #29
Bready
board deviant
 
Bready's Avatar
 
Join Date: Nov 2002
Default

Quote:
Originally Posted by Bready View Post
Replace fuel pump fuse - regardless of what it looks like - and clean the terminals.

At least half of 240 no starts are the result of that fuse.

Costs nothing and it saves you the hassle of the rest of the stuff if that was the issue.
*Sorry missed 12v at pump.
Bready is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:14 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.