home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 01-06-2019, 06:05 PM   #1
red_rocket
Board Member
 
Join Date: Jun 2015
Location: Arizona
Default What part is this?

I have a 1997 S90 and there appears to be a leak at the sensor shown below. It is on drivers side of the engine, just behind the crossmember. I have looked at diagrams of the engine block, but don't see the sensor. I would appreciate any information regarding what sensor this is.



__________________
'91 240; 4 Dr Sedan; Non-Turbo; B230F; 4 Speed Automatic
red_rocket is offline   Reply With Quote
Old 01-07-2019, 04:20 PM   #2
Skavac
Board Member
 
Join Date: Nov 2015
Location: Tangerang, Indonesia
Default

A bit hard to tell from the blurry picture. But it might be the low oil pressure sensor, to trigger the idiot light on the instrument panel.
__________________
1997 S90 Royal LWB, DD, 400k miles, It's Purple!
1992 Volvo 960 Executive, B6304G
1976 Volvo 264, B230E, M47 5spd
Skavac is offline   Reply With Quote
Old 01-07-2019, 10:57 PM   #3
MasterBlaster
Board Member
 
Join Date: Feb 2009
Location: Port Coquitlam
Default

Quote:
A bit hard to tell from the blurry picture.
This is the best I could do. Better?




And the probable switch in question...


__________________

1990 740GL, now in extra-small economy size.
466,000 km so far...
MasterBlaster is offline   Reply With Quote
Old 01-08-2019, 06:23 PM   #4
red_rocket
Board Member
 
Join Date: Jun 2015
Location: Arizona
Default

I think that is the part. Thank you both for your help.
red_rocket is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:40 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.