home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 08-08-2017, 01:49 PM   #1
rokaskey
Newbie
 
Join Date: Mar 2017
Default Lh 2.4 intermitent no signal to injectors

I have an intermitent problem with the lh2.4 injectors
One day it cranks over but cant grab. When checking the diagnostics (3rd stage) the injectors give no life
The next day it starts with no problem

What could be causing the issue?

Specs:
Lh 2.4
Ez-116k
B234f
rokaskey is offline   Reply With Quote
Old 08-08-2017, 01:54 PM   #2
KeizerBrickGuy
Board Member
 
KeizerBrickGuy's Avatar
 
Join Date: Jun 2016
Location: Keizer, OR
Default

Check all grounds and connections for pin push out. I always start there when troubleshooting.
__________________
-Stephen
Quote:
Originally Posted by 87_240TURBO View Post
#mclovethesenuts

-My car: White 1991 244, 308k miles. B230F LH2.4, AW70, R134a retro. Thrush glasspack, anthracite refinished Coronas
-Wife's car: White 1990 244DL, T cam, 190k miles.B230F LH2.4, AW70 w/aux cooler, Duracool AC, purple refinished Virgos, tow hitch, ipd wagon overload springs.
-PSM 2002 Subaru WRX wagon: 120k miles, Perrin TBE, Perrin turbo inlet, intake, and Y-pipe, GrimmSpeed cross pipe.
Rebuilding EJ207 shortblock to swap in this summer.
KeizerBrickGuy is offline   Reply With Quote
Old 08-08-2017, 02:14 PM   #3
Ryan_R
Board Member
 
Join Date: May 2006
Location: Athens, OH
Default

Check for spark. Power Stage or Cranks sensor. Injectors won't do anything until the spark happens. ECU provides ground. You should at least have 12V to the hot side of the injectors, if not radio suppression relay would be the next port of call.

-Ryan
__________________
Athens, OH
1987 245
1989 245 GL
1989 745 GLE
1991 745 --Regina powered B234F!
1995 945T -- Mildly modded
https://people.ohio.edu/ridgely/e-code.htm/
Ryan_R is offline   Reply With Quote
Old 08-08-2017, 02:29 PM   #4
ZVOLV
<Master Tech>
 
ZVOLV's Avatar
 
Join Date: Nov 2002
Location: California
Default

Check wiring at relay. Worth swapping it over to the other side and using the fan relay for a while.

Injectors would still fire during OBD test with a spark malfunction.

Also worth cleaning and inspecting inlet manifold grounds as they are for the computer.
__________________
No Start Thread
ZVOLV is offline   Reply With Quote
Old 08-09-2017, 02:05 PM   #5
nordmaschine
forced instruction
 
nordmaschine's Avatar
 
Join Date: Feb 2012
Location: The Balkans, BiH
Default

Cleaning grounds is always good and you should do it regardless, but the fact you can even get into DTM3 means they're, at least marginally, fine.


If the LED blinks rapildy as it's supposed to, but injectors stay silent, that usually means they're getting ground/trigger, but you can verify that with a test light between an injector connector - negative terminal and battery.

You probably lack injector +, which is usually due to pin-pullout at RSR connector. Or dead RSRelay in the first place. Pull it out and check the pins, are they level and all. If yes, swap the fan relay in, if not fix the connector. If they stay dead, work upstream from there - pull a diagram out and trace continuity all the way.
__________________
Jetronic is romantic.
- '94 965 - D̶2̶4̶T̶I̶C̶, then M̶5̶0̶B̶2̶5̶ now OM606.962.
- '90 744 turbo 16 valve LPG - B204GT/M90 - trophy w̶i̶f̶e̶ car.
- '89 764 B280F - Daily barge.
- Various 740's, 940's, 960's and a couple of 760's.
Quote:
Originally Posted by Kjets On a Plane View Post
Whiteblocks
Quote:
Originally Posted by AdmiralSenn View Post
I think I might be too stupid to own a car.
nordmaschine is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:59 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.