home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 11-09-2018, 06:39 PM   #1
nel621
Board Member
 
Join Date: Apr 2009
Default central locking but not with key

Having an issue with the central locking. It works if you pull the driver side knob all doors lock/unlock. But it does not work when you close the driver door and use the key. Tried 2 different known good mechanisms but same result. What am I missing?
nel621 is offline   Reply With Quote
Old 11-09-2018, 08:37 PM   #2
57plymouth
Board Member
 
57plymouth's Avatar
 
Join Date: Jul 2015
Location: Blythewood, SC
Default

The ring around the lock is not correctly aligned. It isn't sensing the tumbler turning.
__________________
Sven, the 1991 245
57plymouth is offline   Reply With Quote
Old 11-09-2018, 08:44 PM   #3
nel621
Board Member
 
Join Date: Apr 2009
Default

I'll try again but I do believe it's on there correctly.
nel621 is offline   Reply With Quote
Old 11-09-2018, 11:48 PM   #4
bobxyz
Board Member
 
bobxyz's Avatar
 
Join Date: Aug 2014
Location: Boulder, Colorado
Default

The pull knob and the key lock are two different switches, but wired together in the door. See pics at: http://forums.turbobricks.com/showthread.php?t=322700 or http://forums.turbobricks.com/showthread.php?t=323301
bobxyz is offline   Reply With Quote
Old 11-10-2018, 10:35 AM   #5
nel621
Board Member
 
Join Date: Apr 2009
Default

The wires on the pull knob were fine. On the key lock section a small portion was damaged and new wires soldered replaced that. The other central lock assembly had no wire damage at all. Both did the same thing, pull knob fine, use the key -no go. Will revist this later in the week. Thanks for the link.
nel621 is offline   Reply With Quote
Old 11-10-2018, 10:50 AM   #6
bobxyz
Board Member
 
bobxyz's Avatar
 
Join Date: Aug 2014
Location: Boulder, Colorado
Default

There's 3 wires that come from the relays in the center console through the door hinge area to the switches in the door. Red/Green/Black. One is ground (I'd think black but I don't have the wiring diagrams handy.) The other two go to the lock&unlock relays. The switches are in parallel and either one can connect ground to appropriate lock/unlock relay to energize it.

From what you're describing, it sounds like you have a double failure. You can unplug the switch assembly and check it with an ohm meter, or check it in place with key on and a volt meter, and watch what it does as you activate the switches.
bobxyz is offline   Reply With Quote
Old 11-10-2018, 12:10 PM   #7
8587turbo
Board Member
 
Join Date: Dec 2003
Location: Montana
Default

Once you get that fixed put on a remote open/close.. you'll be happy with results, about $15 Ebay/Amazon.
8587turbo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:12 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.