home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 11-10-2017, 06:46 PM   #1
impolvo
Is always busy
 
impolvo's Avatar
 
Join Date: Feb 2006
Location: Chapel Hill NC
Default 92 740 Regina stumbles at acceleration

92 740 regina stumbles at acceleration from idle
Once revs are up or while driving it has no issues or power loss noted
But starting out from idle the revs go up and down till enough speed is reached

Car has around 500k
Daily driver , automatic
Good cool, wires , plugs , distributor
Iac works temp sensor replaced with known good spare
Suppression relay good

Thinking low fuel pressure ?
Fpr has been replaced so maybe Fuel pump is dying ?

Had idle issues a year ago so I replaced the iac cleaned and adjusted throttle body and tps
__________________
my feedback: http://forums.turbobricks.com/showthread.php?t=221335
Quote:
Originally Posted by Stephen View Post
Thats why you get a mans car... A 740
Quote:
Originally Posted by rancidponymilk View Post
You people keep crushing them, you're going to run out eventually.
impolvo is online now   Reply With Quote
Old 11-10-2017, 08:28 PM   #2
impolvo
Is always busy
 
impolvo's Avatar
 
Join Date: Feb 2006
Location: Chapel Hill NC
Default

I'll replace fuel filter as it's never been done
At least not since I've had it
impolvo is online now   Reply With Quote
Old 11-10-2017, 10:02 PM   #3
kzoc
Board Member
 
Join Date: Jan 2003
Location: Austin, TX
Default

GM coil is known to go bad on these, leading to weak spark.
__________________
Volvo side: 84 242Ti
VAG side: 97 Jett TDI, 02 B5.5 Variant, 09 JSW TDI (Crushed!)
kzoc is offline   Reply With Quote
Old 11-10-2017, 11:02 PM   #4
sbabbs
Board Member
 
sbabbs's Avatar
 
Join Date: Dec 2006
Location: Rushing Lane, Scappoose, OR
Default

But yeah the fuel pumps, in tank only, also known to cause this same problem.
__________________
1988 245 White slicktop M47 Wagon! 2.5L NA 8v going in.
1990 745 B230FT M46 13c A-cam 3.54 540K MILES slippin clutch
1991 740SE B230FT NPR Strut braces IPD bar A cam 550cc EV14's. M90 to put in.
sbabbs is offline   Reply With Quote
Old 11-11-2017, 12:11 AM   #5
impolvo
Is always busy
 
impolvo's Avatar
 
Join Date: Feb 2006
Location: Chapel Hill NC
Default

Quote:
Originally Posted by kzoc View Post
GM coil is known to go bad on these, leading to weak spark.
I replaced it with known good unit
impolvo is online now   Reply With Quote
Old 11-11-2017, 12:12 AM   #6
impolvo
Is always busy
 
impolvo's Avatar
 
Join Date: Feb 2006
Location: Chapel Hill NC
Default

Quote:
Originally Posted by sbabbs View Post
But yeah the fuel pumps, in tank only, also known to cause this same problem.
I'll do filter since I have one then pump if it doesn't clear up

Will post results
impolvo is online now   Reply With Quote
Old 11-11-2017, 05:54 PM   #7
impolvo
Is always busy
 
impolvo's Avatar
 
Join Date: Feb 2006
Location: Chapel Hill NC
Default

Changed filter and fixed the issue

So no idea if it is weak pump and partially plugged filter or just plugged filter

Either way fixed
impolvo is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 01:46 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.