home register FAQ memberlist calendar

Go Back   Turbobricks Forums > General > showroom

Reply
 
Thread Tools Display Modes
Old 11-11-2018, 10:24 PM   #1
lunchb0x
Board Member
 
lunchb0x's Avatar
 
Join Date: Nov 2007
Location: Modesto, CA
Default On the DL - 1985 Volvo 244 DL

Hey all.

I just picked up this 1985 244 DL Manual from my roommate's dad for $1000. He had it for a month or so with the plans to make it nice daily but ended up selling it to me. The guy who had it before him put a lot of work into getting it to pass smog. It passed with flying colors and the A/C works!

My current plans are to get all the stage 0 maintenance done and then get a nice exhaust and an A or B cam to waken it up a little.

Here it is currently in the garage with the interior pulled out. I "borrowed" the turbo grill from BR1CKHOUS3.


I changed the oil on Friday and did the motor mounts and trans mount yesterday... Should have done the oil change last as the filter is a bitch to work around, especially the larger WIX filter.
Mounts were a little worn..



Replaced the fuel filter and found a pinched line coming off the filter as well as the awesome bungee cord brace.



Started cleaning the interior, carpet cleans up pretty nice.


So much dog hair in the car, at least they left me a treat!


There was even dog hair stuck in the window seal.... I used an old electric razor to trim it



Here's my old '89 740 Turbo I had parked next to BR1CKHOUS3's 242.
__________________
Quote:
Originally Posted by B Mac66 View Post
Running a stock exhaust is pretty much the equivalent of trying to run a mile while you hold a pillow over your face.....
Quote:
Originally Posted by gamby242 View Post
Wait a second. Safety on turbobricks?
You're concerned about safety?!?!?
Our cars are held together with zipties and jb weld.
lunchb0x is offline   Reply With Quote
Old 11-11-2018, 10:44 PM   #2
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

Dog hair is good. Embrace it and contemplate on mans best friend. Nice score!
__________________
1979 242 B21 on MS, waiting on L33
1991 740t RIP at 320K, dam rust...
2006 V50 T5 AWD Eurosport Tuning Stage 1 kit, downpipe, intercooler
2turbotoys is offline   Reply With Quote
Old 11-12-2018, 11:01 PM   #3
lunchb0x
Board Member
 
lunchb0x's Avatar
 
Join Date: Nov 2007
Location: Modesto, CA
Default

I love dogs, just would prefer the hair to be of one I owned lol.

Scored a tach and headlight reflector at Pick N Pull today.

It works!


I noticed while under the car this weekend that the exhaust has a few pin hole leaks in the welds and is running underneath the axle and clanking around. That's next on the fix list once funds become available.

Last edited by lunchb0x; 11-13-2018 at 01:02 PM..
lunchb0x is offline   Reply With Quote
Old 11-13-2018, 04:37 AM   #4
benski
Board Member
 
Join Date: Jul 2008
Location: Olympic Peninsula, Wa. State
Post

Dog treat AND 17 cents an hour? You've struck it rich! Seriously, lookin' good.
benski is offline   Reply With Quote
Old 11-15-2018, 01:38 AM   #5
BR1CKHOUS3
740s are Volvos too
 
BR1CKHOUS3's Avatar
 
Join Date: May 2016
Location: Modesto, CA
Default

__________________
We don't do it for the glory.
Quote:
Originally Posted by SlowRide View Post
Only two ways to find out...18 bolts or 18psi
BR1CKHOUS3 is offline   Reply With Quote
Old 11-15-2018, 11:57 AM   #6
Double02
Board Member
 
Double02's Avatar
 
Join Date: Dec 2009
Location: Vancouver
Default

Man, my 244 had enough dog hair under the seats to make two extra dogs. Your car will smell so much better after all of that is gone.
__________________
Bruce

'58 Citroen 2CV - Grey
'82 Peugeot 604 - Black
'85 Renault R5 - Silver
'91 Mazda Miata - BRG
'06 V70 2.5T - Grey
Double02 is offline   Reply With Quote
Old 11-26-2018, 09:35 PM   #7
BR1CKHOUS3
740s are Volvos too
 
BR1CKHOUS3's Avatar
 
Join Date: May 2016
Location: Modesto, CA
Default

Looked good at the last meet

BR1CKHOUS3 is offline   Reply With Quote
Old 11-26-2018, 10:41 PM   #8
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

Those are some shiny 14's! The ones I took off my car look like they were stored in the ocean. For about 10 years...
2turbotoys is offline   Reply With Quote
Old 11-27-2018, 02:37 PM   #9
lunchb0x
Board Member
 
lunchb0x's Avatar
 
Join Date: Nov 2007
Location: Modesto, CA
Default

Quote:
Originally Posted by 2turbotoys View Post
Those are some shiny 14's! The ones I took off my car look like they were stored in the ocean. For about 10 years...
I was fortunate to get them in good shape. Had a friend of mine do a quick polish of the rings and centers. I sanded down the center caps and polished the outer ring and V, then had BR1CKHOUS3 spray them black. The steelies themselves were nasty but cleaned up all right, at least the parts you can see that is. They aren't perfect but are definitely 5ft pretty.

After spraying and removing the masking tape.

Close up of the finished work.
lunchb0x is offline   Reply With Quote
Old 11-27-2018, 10:45 PM   #10
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

Those centers fit 15" steelies also, I used them for a while. Looks great!
2turbotoys is offline   Reply With Quote
Old 12-01-2018, 10:26 PM   #11
lunchb0x
Board Member
 
lunchb0x's Avatar
 
Join Date: Nov 2007
Location: Modesto, CA
Default

Good to know! I'd like to find a set of Volans sometime in the future and lower it down on those. I've always loved the look of Volans.

Did a bit of maintenance over the last few days.

-Cleaned throttle body
-Cleaned IAC motor
-Cleaned MAF
---On cold start the car properly revs up higher then settles back down once it begins warming up, didn't seem to do that before with everything dirty
-Fixed the driver side defrost vent, had to reconnect the diaphragm to the lever

Still fighting with the Overdrive light. OD engages and disengages just fine but the light doesn't come on in the dash. I've checked the bulb and it works fine. Noticed someone cut the wire for the OD light on the cluster harness and replaced it with another wire. I traced it back to the OD relay by the glove box. I reconnected the original wire and still no light.


Flushing the transmission is next on my maintenance list. The OD sump pan is leaking a little so before I put too many more miles on it I want to flush it. Don't know how long its been leaking or how much fluid has leaked out.
lunchb0x is offline   Reply With Quote
Old 12-01-2018, 10:56 PM   #12
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

Apply direct 12v to the OD light and see if it works? bulb?
2turbotoys is offline   Reply With Quote
Old 12-01-2018, 11:34 PM   #13
lunchb0x
Board Member
 
lunchb0x's Avatar
 
Join Date: Nov 2007
Location: Modesto, CA
Default

Yeah I've done that and the bulb is good. I even swapped a different bulb/housing in and still nothing. I might try and rig up a test light outside the cluster, directly off the relay and see what happens.
lunchb0x is offline   Reply With Quote
Old Yesterday, 04:39 PM   #14
BR1CKHOUS3
740s are Volvos too
 
BR1CKHOUS3's Avatar
 
Join Date: May 2016
Location: Modesto, CA
Default

So...things are going well

BR1CKHOUS3 is offline   Reply With Quote
Old Yesterday, 11:09 PM   #15
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

That looks like it sucks to be you right now lol, whatcha doing there
2turbotoys is offline   Reply With Quote
Old Yesterday, 11:58 PM   #16
Redwood Chair
K-jet For Life
 
Redwood Chair's Avatar
 
Join Date: Mar 2007
Location: - Stock PSI Or Bust -
Default

Stripped nut on the drag link end?
__________________
Raise The Lowered


Image hosted by servimg.com

Quote:
Originally Posted by hiperfauto View Post
Folks on here don't know a good deal when they see it.
how psi stock cna support?

Redwood Chair is offline   Reply With Quote
Old Today, 02:24 AM   #17
lunchb0x
Board Member
 
lunchb0x's Avatar
 
Join Date: Nov 2007
Location: Modesto, CA
Default

Well dip**** me, moving too quickly, put the tie rod end upside down and sent it with an impact. Had to use that fine setup to stop the bolt from spinning so I could get the nut off. Replaced the tie rod end with a new one and all is good.

Cut 2 coils off the front and 1.25 off the rear and the car is looking good. Will post some pics tomorrow.
lunchb0x is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:26 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.