home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > performance & modifications

Reply
 
Thread Tools Display Modes
Old 08-07-2020, 05:57 AM   #1
Ozzyd2
Newbie
 
Join Date: Jul 2017
Default 91’ 940se (*wont start*)

Howdy fellow Volvo nuts
Greetings from sunny California, Los Angeles
Got a 91’ 940se wagon
Did a few mods to my wagon and haven’t been able to start it up successfully, gonna explain my dilemma and see if any of you guys can share some advice cause I’m at a standstill at the moment...

Mods done:
Machined head (530)
Ipd turbo cam
Ipd adjustable cam gear
Green injectors (relay mod)
15g turbo (19t internals)
3” MAF
3” downpipe/full exhaust
Blaster coil
eBayChip (stage4)on both ecu and ezk (gold box)
Welded diff
Full ipd suspension
A/C delete
Oil catch can
Dual stage boost controller


Engine cranks over and starts up after a few times but needs throttle to be applied and moment throttle is released the engine cuts off, no real idle. Wondering if maybe someone here can help and shed some light cause I’m head scratching at the moment.
Much appreciated.

I’ll include some photos




Ozzyd2 is offline   Reply With Quote
Old 08-07-2020, 06:47 AM   #2
Fa182
Stage 1
 
Fa182's Avatar
 
Join Date: Apr 2016
Location: Austria
Default

Did you have those issues before you did any of the mods?
What's that yellow thing at the distributor?
Is that the catch can above the turbo?

Start with the easy stuff first.
TPS and linkage is correctly adjusted? Throttle body is clean?
Idle valve is clean and functional?
__________________
Fa182 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:50 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.