home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 05-16-2019, 12:24 AM   #1
Haystack
Board Member
 
Join Date: Feb 2017
Location: NorCal
Default Something Strange Happened, Ideas?

I was driving to work this morning in my 87 240, it was raining and I was cruising in the hammer lane. All of a sudden I felt a sudden loss of power and there was a noticeable hum/vibration. I got over in the slow lane in case I needed to pull over, but I didn't see any warning lights so I kept going and it went away after a minute. It seemed fine the rest of the way to work. After work I got in my car and noticed the overdrive arrow light and the engine oil light were slightly illuminated and were softly flickering (before I even put the key in the ignition). I checked the engine oil and it was fine so I started it up and there was no lights on. It seemed fine on the way home, but defiantly something strange going on. Any ideas?
__________________
1987 244DL
Haystack is offline   Reply With Quote
Old 05-16-2019, 07:51 AM   #2
dbarton
Dejected by Volvo
 
dbarton's Avatar
 
Join Date: Nov 2002
Location: North of Dallas
Default

Quote:
Originally Posted by Haystack View Post
I was driving to work this morning in my 87 240, it was raining and I was cruising in the hammer lane. All of a sudden I felt a sudden loss of power and there was a noticeable hum/vibration.
Can you rule out the possibility that the OD turned off and the hum/vibration was the transmission shifting to 3rd?

This is a fairly common issue. Sometimes caused by an intermittent relay or possibly rain related with a marginal harness/connection to the trans under the car.
Dave B.
__________________


'84 242ti, owned since 2003. Always garaged since brand new. Old-school rounds because. B21FT, iPd Springs/Sways, SDS EFI/IGN, TD04HL-15G, T5Z trans with 0.73 OD retrofitted, 3.91 diff with G80.
Volvo seeks Divorce from Volvo Enthusiast Community: www.prancingmoose.com/#novolvo
Dave's Volvo Page: www.davebarton.com
dbarton is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:13 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.