home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 05-16-2019, 12:09 PM   #1
xDread92x
Board Member
 
xDread92x's Avatar
 
Join Date: Feb 2015
Location: NC
Default AC Compressor Question

I was doing some research and it seemed many say the rebuilt ac compressors are junk. I guess mainly because they are rebuilt poorly. They have a 1 year warranty which helps. I cant afford a new one by any means and I'm on the verge of an AC rebuild in the 240.

Thoughts?
__________________
Image and video hosting by TinyPic
xDread92x is offline   Reply With Quote
Old 05-16-2019, 02:32 PM   #2
dl242gt
300+hp on the shelf club
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

I've never used a rebuitl a/c compressor of the rotary type. But if the company will warranty their work and the warranty replacement isn't a horrible process. Then that may be worth a try. I bought a new one when I redid the a/c on my 93. It was only $265 for a new one that was a bigger stronger compressor than original.

What refrigerant you are using matters. If you are going to R134 you are better off getting a new compressor designed to run at the higher pressure. The old R12 compressor used on R134 isn't going to last very long.
dl242gt is offline   Reply With Quote
Old 05-16-2019, 03:14 PM   #3
xDread92x
Board Member
 
xDread92x's Avatar
 
Join Date: Feb 2015
Location: NC
Default

Yea these refurbished compressors are only R134A compatible so that shouldn't be an issue.
xDread92x is offline   Reply With Quote
Old 05-16-2019, 03:16 PM   #4
intothelabyrinth
Board Member
 
intothelabyrinth's Avatar
 
Join Date: Mar 2012
Location: Bowling Green, KY
Default

What is the problem with the one on the car?
__________________
1986 245 Auto (RIP)
1986 245 Auto (RIP)
1988 245, M47 (My Daily)
1989 245 Auto California Car
1993 245 Classic (new project for my little brother)
1999 V70 T5 Auto (Girlfriend's Daily)

brokedownbrick.wordpress.com
intothelabyrinth is offline   Reply With Quote
Old 05-17-2019, 12:41 AM   #5
xDread92x
Board Member
 
xDread92x's Avatar
 
Join Date: Feb 2015
Location: NC
Default

Clutch wont spin while belts are running. Pulley spins but clutch doesnt.


No cool air blows out at all
xDread92x is offline   Reply With Quote
Old 05-18-2019, 06:45 AM   #6
TestPoint
Board Member
 
TestPoint's Avatar
 
Join Date: Jul 2009
Location: Ellijay
Default

Jump the low pressure cutoff switch. It the clutch engages you need Freon. If not, you need a compressor.
__________________


1982 Volvo 245 with a Ford 302 V8

Ford V8 Conversion Manual -
http://forums.turbobricks.com/showthread.php?t=250257

Bertone Restoration - http://forums.turbobricks.com/showthread.php?t=256460
TestPoint is online now   Reply With Quote
Old 05-18-2019, 12:24 PM   #7
xDread92x
Board Member
 
xDread92x's Avatar
 
Join Date: Feb 2015
Location: NC
Default

Is the test wire the one coming from the top front of the compressor with the male end?
xDread92x is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:51 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.