home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 09-06-2019, 05:40 PM   #1
xmlhack
Board Member
 
xmlhack's Avatar
 
Join Date: Dec 2005
Location: Palm Bay, FL
Default no power at fuel pump - 1972 142e

tried to start the car for the first time ever, and the new fuel pump issnt getting power. where do i look for the fuse and/or relay?
__________________
71 Volvo 144S - The original
75 Volvo 242DL - College beater
92 Volvo 940GL - Workhorse
95 Volvo 855 - My first HPT
06 Volvo XC90 - Daughter’s Truck
98 BMW 540i - Commuter
72 Volvo 142E - Current project
xmlhack is offline   Reply With Quote
Old 09-06-2019, 07:05 PM   #2
hiperfauto
Board Member
 
hiperfauto's Avatar
 
Join Date: Nov 2011
Location: So Cal
Default

The FI relays are on the right inner fender near the hood hinge. Power for both the main and fuel pump relays comes from the junction block near the battery. Power for the fuel pump goes through a fuse in the small fuse box near the headlight relay on the left inner fender. That fuse may be your problem.

The main relay is activated by a yellow wire that is connected to the (+) side of the coil. The fuel pump relay should run for 1 second when the ignition is turned on.

Last edited by hiperfauto; 09-06-2019 at 08:04 PM..
hiperfauto is online now   Reply With Quote
Old 09-07-2019, 12:02 PM   #3
xmlhack
Board Member
 
xmlhack's Avatar
 
Join Date: Dec 2005
Location: Palm Bay, FL
Default

thanks for the tips. i've seen that junction block. it looked broken. i will pull the battery and check that out. My Haynes describes the poles for checking the relays. I've seen the fuse box for the pump. it has a thumb screw on the face. i'll check that too. i hope to be driving it soon.
xmlhack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:08 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.