home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 02-17-2015, 01:11 AM   #1
james619
Newbie
 
Join Date: Feb 2015
Default 1993 940 turbo, dies after starting, once going all is fine

I just bought a 940 turbo a few weeks ago, the car just developed the issue. When I start the car (cold or hot from running) it starts & immediately stalls out, if I give it some gas it stays on for me to shift it in to drive & then the car runs perfectly. Also the car takes a bit to start up.

So i posted this on another board...guy there said to try the check valve located on the fuel pump...i installed a new one, but has no effect.....2 other things is that the car kicks out a touch of white smoke after starting & also gets very mediocre gas mileage...please help!!
james619 is offline   Reply With Quote
Old 02-17-2015, 01:21 AM   #2
CJs 142E
Board Member
 
CJs 142E's Avatar
 
Join Date: Aug 2005
Location: Portland OR,
Default

Check Temp Control sensor under the intake.. it's plugged into the head It has specific ohm's when hot and cold.. Do a leak down test, check for oil in water or water in oil. Then check your ICV (Idle Control Valve under the intake) Good Luck..
__________________
72 142 Turbo Project (In the works)
Join My Group > http://forums.turbobricks.com/group.php?groupid=97


72 142Turbo
73 145
06 V70R Sonic Blue
CJs 142E is offline   Reply With Quote
Old 02-17-2015, 11:51 PM   #3
james619
Newbie
 
Join Date: Feb 2015
Default

it was the fuel pressure regulator :-) its running great now
james619 is offline   Reply With Quote
Old 02-18-2015, 01:25 AM   #4
CJs 142E
Board Member
 
CJs 142E's Avatar
 
Join Date: Aug 2005
Location: Portland OR,
Default

Quote:
Originally Posted by james619 View Post
it was the fuel pressure regulator :-) its running great now
NICE!!!
CJs 142E is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 05:43 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.