home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 04-03-2021, 09:18 AM   #1
martijn266
Newbie
 
Join Date: Apr 2020
Location: Zeeland, Netherlands
Default 940 rough idle

Hello,

I know this topic has been covered many times but I couldn't find my exact 'thing'

A few months ago I upgraded my 940 b230ft to a 16t turbo, chips, injectors etc. Last week I installed a new lightened flywheel and 850r clutch. Before the flywheel it was running great, no rough idle and no lean idle. Now after the light flywheel install the first two minutes of startup the idle is really rough and the wideband reads 19.5ish, normally this is 14.5ish. After two minutes the idle becomes normal and the afr's flatten out to 14.5.

I have counted the timing notches on the flywheel (60-2) and have placed the -2 part on the same place as before.

I dont really want to drive the car when it is running lean but my neighbours also don't like it when I let the car idle for 2-3 mins at 05:45 in the morning
__________________
'97 940se. B230ft, upgraded intercooler, 16T turbo ran at 17 psi, 3" turboback exhaust, 470cc injectors and Bijlsma stage 3 7000rpm chiptune.
IPD turbo cam coming up...
martijn266 is offline   Reply With Quote
Old 04-03-2021, 03:21 PM   #2
dl242gt
Happy playing the blues
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

A 'tuned' engine on these cars tends to run rough when cold. This happened to me when I installed a cam in my car. I clear it out every cold start. Be aware that the engine will not be as smooth as it was because you removed one of the biggest factors for making a smooth idle which is the heavy flywheel. The AFR you observed seems fine to me. You can verify the flywheels is installed properly by removing the starter and putting the engine at top dead center. The missing hole should be in the bottom of the hole for the starter. I'd also make sure your engine mounts are in good condition. Your car probably has the hydraulic mounts which add vibration when they have failed.
__________________
Dave,
1982 242 turbo. 338k miles. MVP coilovers and 3" exhaust. Flowed 405 with a V15. Cossie turbine housing with upgraded compressor housing. 90+, IPD remote oil filter. Some other goodness, too. Been lots of fun over 25 years. Restored in 2k. Now ready for a 2nd restoration.

1993 245 Classic, 430k miles, enem V15. IPD bars and chassis braces. Simons sport exhaust from Scandix. sbabbs ezk chip. Been a good road warrior. Genuine Volvo rebuilt leaky M47.
dl242gt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 10:46 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.