home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

Reply
 
Thread Tools Display Modes
Old 05-31-2019, 11:55 AM   #526
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Quote:
Originally Posted by Harlard View Post
Wouldn't it be easier to just get a 60e for the wagon and store/sell the 80e?
yea it would probably be best to store it since unless you have a standalone that 80e is completely worthless
__________________
1979 Volvo 244DL 5.3/4l80e,8.8,Ms3x goldbox ecu and Mircrosquirt tcu, GTX4202r, 226/230 turbo cam, tbss intake, 11.0@128mph 9psi, 3600lbs with driver
1974 AMC Gremlin, 401 v8, 727, 8.8
1995 Porsche 993
2013 VW Passat TDI
Quote:
Originally Posted by bricktop420 View Post
Thank you very much everybody... i now feel sufficiently retarded and will go cry in the corner...
cosbySweater is offline   Reply With Quote
Old 05-31-2019, 09:21 PM   #527
Texas240
Prius Owner
 
Texas240's Avatar
 
Join Date: Jul 2008
Location: Dallas, TX
Default

Quote:
Originally Posted by Harlard View Post
Wouldn't it be easier to just get a 60e for the wagon and store/sell the 80e?
And the 60e us easy to rebuild and find parts
__________________
93 245 LS Engine Swap Project
Texas240 is offline   Reply With Quote
Old 05-31-2019, 10:51 PM   #528
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

it is, no plans on positive pressure so it should be okay, but if it breaks, it will not be shocked.
cosbySweater is offline   Reply With Quote
Old 06-01-2019, 01:35 PM   #529
stevE85
Formerly 1983_242
 
stevE85's Avatar
 
Join Date: Mar 2011
Location: Benicia, CA
Default

Quote:
Originally Posted by cosbySweater View Post
it is, no plans on positive pressure so it should be okay, but if it breaks, it will not be shocked.
What's the point without positive pressure?
__________________
1982 244-"Ivory Blanco" GM L33/5.3L, T56, Mcleod twin disc, Gen 2 billet 7875, 44mm gate, 2.50 Hot/Cold sides, LJMS Stg2 turbo cam, PAC springs, H2O/Meth, 9.5psi/@13*, Etc.
stevE85 is offline   Reply With Quote
Old 06-01-2019, 04:44 PM   #530
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Because I'm going to lift it and shift it. Also in other news.the 6.0 seems to have healed itself by sitting in the street for a month. Very mysterious
cosbySweater is offline   Reply With Quote
Old 06-01-2019, 05:39 PM   #531
Texas240
Prius Owner
 
Texas240's Avatar
 
Join Date: Jul 2008
Location: Dallas, TX
Default

Quote:
Originally Posted by cosbySweater View Post
Because I'm going to lift it and shift it. Also in other news.the 6.0 seems to have healed itself by sitting in the street for a month. Very mysterious
Lucas electronics?...Prince of darkness. That happens.
Texas240 is offline   Reply With Quote
Old 06-01-2019, 06:56 PM   #532
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

I have no idea. It was running so bad and had insane blow by and today I started it and it was fine. Oh well. Aluminum 5.3 is in and almost ready to drive
cosbySweater is offline   Reply With Quote
Old 06-02-2019, 12:36 PM   #533
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

so far so good with the 5.3 in. after all of the work ive done to it i will say with this true turbo cam in the car it is so much nicer to drive. it is much quieter at idle and feels alot better getting into boost. im going to pull the 6.0 apart tomorrow and see what happened to it. but my guess is that the rings have just lost tension in it. ill hold onto it and see what im going to do with it. at this point i feel like im going to narrow the fleet down and as of now the fairmont and i think my wagon are on the chopping block. i really do want to lift the wagon and throw the 6.0 in it and chances are that may still happen but at this point i have to think about being practical. i could daily the 993 but it would be destroyed within a month as far as the interior goes.
cosbySweater is offline   Reply With Quote
Old 06-04-2019, 02:09 PM   #534
Andrewhans
Turbo LS ****poster
 
Andrewhans's Avatar
 
Join Date: Jan 2013
Location: Kenly, NC
Default

Funny that the 6.0 fixed itself.

The quieter idle on the 5.3 is that with the new Summit Turbo Cam? I'm REALLY curious how those do. Somedays I wish I would have gone with that vs the SS2 but I love the sound of the SS2 and was tired of a boring factory idle lol
__________________

Current setup - Aluminum L33/Summit Turbo Stage 2/Gen 1 Billet 7875, single Walbro 450 and Dual AEM 400's, Bosch 210's
60' 1.51 - 1/8 6.38 @ 110.8mph - 1/4 xxx
3060lb no driver
3240lb with driver
Andrewhans is offline   Reply With Quote
Old 06-04-2019, 03:41 PM   #535
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

It idles like the ls1 cam. It's really nice
cosbySweater is offline   Reply With Quote
Old 06-16-2019, 12:58 AM   #536
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Welp swapped engines, car felt great. Then it lost oil pressure. Haha engines coming back out. Bought another car and unloading some of the projects.

cosbySweater is offline   Reply With Quote
Old 06-16-2019, 03:40 PM   #537
122power
dude
 
122power's Avatar
 
Join Date: Feb 2009
Location: Where have all the quad squares gone? VV,Ca
Default

Ewwww a vw.
__________________
Post pics in Orhpan Thread or YOU will be banned.
122power is offline   Reply With Quote
Old 06-17-2019, 02:27 AM   #538
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Quote:
Originally Posted by 122power View Post
Ewwww a vw.
Yep! Considering it was cheaper then a extremely clean 245. I'm totally fine with that
cosbySweater is offline   Reply With Quote
Old 06-17-2019, 12:12 PM   #539
stevE85
Formerly 1983_242
 
stevE85's Avatar
 
Join Date: Mar 2011
Location: Benicia, CA
Default

Der Volkswagen is nice, I'm still considering one. Your 5.3L lost oil pressure already?
stevE85 is offline   Reply With Quote
Old 06-17-2019, 03:14 PM   #540
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Yep after hammering on it for a bit. I'm guessing cam bearing. If I didn't have bad luck with these on initial fire up I would have no luck at all
cosbySweater is offline   Reply With Quote
Old 07-20-2019, 01:23 AM   #541
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Welp Volvo self healed. Haven't driven it much but I got another cool car with another tbricker



cosbySweater is offline   Reply With Quote
Old 07-21-2019, 03:07 PM   #542
122power
dude
 
122power's Avatar
 
Join Date: Feb 2009
Location: Where have all the quad squares gone? VV,Ca
Default

Rumble rumble
122power is offline   Reply With Quote
Old 07-21-2019, 05:26 PM   #543
Sjeng
Board Member
 
Sjeng's Avatar
 
Join Date: Sep 2017
Default

That thing is epic. What is that? Looks a bit like a AMC pacer.
Sjeng is offline   Reply With Quote
Old 07-21-2019, 07:05 PM   #544
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

It's a AMC gremlin with a 390 AMC V8 swapped in it
cosbySweater is offline   Reply With Quote
Old 07-24-2019, 09:12 PM   #545
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Took apart the 6.0 finally, it was just tired after all that hard abuse, this thing did hold up extremely well!




You can see the pistons were getting a little melty!

Got new wheels for the gremmie as well! Fronts are 0 offset 15x7 rear are 15x8 0 offset, tires are some old Hoosier radials 215/65r15.

cosbySweater is offline   Reply With Quote
Old 09-09-2019, 02:19 PM   #546
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Worked on the 244 a bit last weekend, ever since before Davis I've noticed the car had some intermittent lack of power issues. After the swap to the 5.3 I knew there was going to be a bit of a response difference compared to the 6.0 but it was randomly do bad that it felt like it may as well not have a turbo. I finally sawzalled off the driver's side of the turbo crossover and found the flex coupling to have a ton of holes in it and it had started to collapse. Had my buddy Tig a 2.25 vband on the side that remained in the car and installed a new vibrant turbo flex in there. It feels alot more consistent now. Did a little bit of street tuning and turned the boost up to about 18ish psi, and about 10 degrees up top, car feels great but I do miss the 6.0. I have been thinking about throwing some better heads on this thing but at the same time I think I'm just going to leave it. I have a new intercooler that I'm going to throw in sooner rather then later. Modify the valve cover on the passenger side and do a 4 inch down pipe on it to a 3.5 after the trans and straight out the back. The current intercooler setup is super not ideal. Outlet on the turbo is 3.75 inches, it necks down to a 2.5, into a 22x7x2.5 ic and then into a 92mm throttle body. I've been leaving so much on the table as far as efficiency goes and I need to iron all of that stuff out.

In other news, ran into the original owner of my new gremlin. Found out alot of cool stuff out about the engine and why it's such a bear to drive. It has a 390 AMC block, forged 401 crank and rods and some high compression je pistons with a full Edelbrock top end kit. I'm starting a thread on it on the AMC forums and I'll link it in my signature if any one is interested in it.
cosbySweater is offline   Reply With Quote
Old 09-09-2019, 08:20 PM   #547
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

Like the Gremlin! They always look like they want to pull wheelies haha
__________________
Feedback thread https://forums.tbforums.com/showthread.php?t=144924

1978 242, getting prepped for LS
1979 242, MS, R brakes
2006 V50 T5 AWD @ 17 PSI
2turbotoys is offline   Reply With Quote
Old 09-09-2019, 10:00 PM   #548
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Quote:
Originally Posted by 2turbotoys View Post
Like the Gremlin! They always look like they want to pull wheelies haha
Haha thanks, can't wait to get it dialed in and take it to the track!
cosbySweater is offline   Reply With Quote
Old 09-09-2019, 10:17 PM   #549
2turbotoys
Salaminizer
 
2turbotoys's Avatar
 
Join Date: Nov 2007
Location: Reading pa
Default

Post a vid when you get there! Would love to see it.

Luckily for me, the guys I bought my aluminum 5.3 from ran it on the dyno and found worn cam bearings before they shipped it to me, common problem I suppose? I don't know... I had them put a cam in and fix the bearings way cheaper than I could have done it. What heads do you have on it? I have a couple sets of heads, currently have the 799 heads on it.
2turbotoys is offline   Reply With Quote
Old 09-09-2019, 11:30 PM   #550
Duder
Comes with a free Frogurt
 
Duder's Avatar
 
Join Date: Dec 2009
Location: Torrance, CA
Default

That's a badass Gremlin. I like the wheel & tire combo.
Duder is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:18 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.