home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > performance & modifications

Reply
 
Thread Tools Display Modes
Old 07-14-2020, 07:54 PM   #1
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default China turbo- too much preload?

I'm getting some boost spikes up to 20psi. I reclocked it and set the preload at about 3/4 of the length of the hole on the waste gate actuator rod. I took my mbc apart and didn't see anything unusual. 2 balls and a spring, I have it set so that it opens when I blow in it so it's not 20psi. Pretty sure it's hooked up right, hose on the bottom goes to the turbo outlet and the one on the side goes to WG actuator. Anyway any ideas?
__________________
"i will destroy all of you!"
-Sheldon Plankton

Booty Scooty
https://youtu.be/i4oAOZ8nbq4
VB242 is offline   Reply With Quote
Old 07-14-2020, 08:14 PM   #2
culberro
Ronald Culberbone III
 
culberro's Avatar
 
Join Date: Feb 2010
Location: Portland, OR
Default

What does it do when the actuator is hooked up directly to the compressor housing?
__________________
Cult Person. Pissing in your Kool-Aid.
culberro is online now   Reply With Quote
Old 07-14-2020, 08:30 PM   #3
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default

Quote:
Originally Posted by culberro View Post
What does it do when the actuator is hooked up directly to the compressor housing?
That's a good question, I'll try that next.
VB242 is offline   Reply With Quote
Old 07-14-2020, 09:04 PM   #4
TurboDutch
Board Member
 
Join Date: Aug 2019
Location: Nieuw en Sint Joosland
Default

Chinabai charger with internal wastegate? Could be boost creep.
Try porting wastegate hole?

Last edited by TurboDutch; 07-16-2020 at 02:59 PM..
TurboDutch is offline   Reply With Quote
Old 07-16-2020, 02:43 PM   #5
MadDog_945
Våga Vägra 8V
 
MadDog_945's Avatar
 
Join Date: Apr 2006
Location: Lower Saxony
Default

Quote:
Originally Posted by TurboDutch View Post
Chinabai charger with internal wastegate? Could be boos creep.
Try porting wastegate hole?
this!
MadDog_945 is offline   Reply With Quote
Old 07-16-2020, 02:49 PM   #6
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default

I just adjusted the ve map, 20psi is fun.
VB242 is offline   Reply With Quote
Old 07-19-2020, 01:17 PM   #7
MadDog_945
Våga Vägra 8V
 
MadDog_945's Avatar
 
Join Date: Apr 2006
Location: Lower Saxony
Default

the turbobricks way ;)
MadDog_945 is offline   Reply With Quote
Old 07-19-2020, 05:10 PM   #8
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default

Best run today, I have an appointment with the dyno on the 29th to finish sorting it out.

VB242 is offline   Reply With Quote
Old 07-19-2020, 08:42 PM   #9
Alan29
Board Member
 
Alan29's Avatar
 
Join Date: Jun 2019
Location: Tampa, FL
Default

Nice run...car sounds great.
__________________
Signature.
Alan29 is offline   Reply With Quote
Old 07-19-2020, 09:48 PM   #10
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default

Quote:
Originally Posted by Alan29 View Post
Nice run...car sounds great.
Thanks!!
VB242 is offline   Reply With Quote
Old 07-29-2020, 12:21 PM   #11
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default

So I took the heap to the dyno, apparently I need to port the wastegate. Will keep all apprised of further developments. I wish I’d listened to Culberro.
VB242 is offline   Reply With Quote
Old 07-29-2020, 12:23 PM   #12
linuxman51
BRANDSCHUTZVORSCHRIFTEN!
 
linuxman51's Avatar
 
Join Date: Dec 2002
Location: mont, AL
Default

lol! so what'd it throw down?
__________________
"They bum rushed them in their own crib, they drank all their beer, they partied with their ladies and they left with the trophy"

Now with in-house Dyno tuning!

Megasquirt Tuning!
Plug and play LH 2.4 Megasquirt, now with stealth mode!
linuxman51 is offline   Reply With Quote
Old 07-29-2020, 12:23 PM   #13
culberro
Ronald Culberbone III
 
culberro's Avatar
 
Join Date: Feb 2010
Location: Portland, OR
Default

Dyno plots and boost spikes or
culberro is online now   Reply With Quote
Old 07-29-2020, 12:33 PM   #14
TurboDutch
Board Member
 
Join Date: Aug 2019
Location: Nieuw en Sint Joosland
Default

Creep!
TurboDutch is offline   Reply With Quote
Old 07-29-2020, 02:11 PM   #15
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default

234 -240 before he let up around 5500rpm in 3)3rd gear pulls. Explains why none of my boost controllers are working.
VB242 is offline   Reply With Quote
Old 07-29-2020, 11:20 PM   #16
linuxman51
BRANDSCHUTZVORSCHRIFTEN!
 
linuxman51's Avatar
 
Join Date: Dec 2002
Location: mont, AL
Default

DATA MAN, DATA!

seriously. n00ds or gtfo, you know the rules.
linuxman51 is offline   Reply With Quote
Old 07-30-2020, 08:54 AM   #17
VB242
F*ck 12
 
VB242's Avatar
 
Join Date: Sep 2011
Location: In my 15x20 Corona cell
Default




The knock sense is going off quite a bit, we were going to look at the that too. I think I have it turned all the way down but it seems to go off as soon as boost kicks in. The knock sensor is torqued to 10ft.lbs. in the spot at the center top of the left side of the block where the factory sensor was installed
VB242 is offline   Reply With Quote
Old 07-30-2020, 10:08 AM   #18
TurboDutch
Board Member
 
Join Date: Aug 2019
Location: Nieuw en Sint Joosland
Default

Looks not bad... only a bit lean.... needs more fuel :D
TurboDutch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:59 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.