home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 07-31-2020, 05:02 PM   #1
HighMans
Board Member
 
Join Date: Mar 2019
Default Car Stalling & Acceleration issues

'91 740 B230F+T

Was driving down the road and car stalled out while at a light. Tried to restart and it was running super rough, would stutter and then die. I put it in to park tried starting with full pedal and the car wouldn't die but stumbled/shook very hard.

The AFR was reading super clean and sometimes it would rev super high but then drop out and go back to stuttering.

It finally got back to normal and I got home, but now I'm idling at an afr of 13 instead of 14.5-15...
HighMans is offline   Reply With Quote
Old 07-31-2020, 05:31 PM   #2
iamrolling
Board Member
 
Join Date: Nov 2019
Default

Did you already try cleaning the throttle body and MAF wire with the appropriate spray can for each task?
iamrolling is offline   Reply With Quote
Old 07-31-2020, 05:32 PM   #3
HighMans
Board Member
 
Join Date: Mar 2019
Default

Quote:
Originally Posted by iamrolling View Post
Did you already try cleaning the throttle body and MAF wire with the appropriate spray can for each task?
Yes, a long while ago.
HighMans is offline   Reply With Quote
Old 07-31-2020, 05:45 PM   #4
iamrolling
Board Member
 
Join Date: Nov 2019
Default

How many miles ago? I only do it every 40-50k and only because so many miles have passed, but I've heard of some turbo car owners having to clean at least the TB every 10k or they start having issues. Look for failed air hoses too. I don't know how your F+T is set up, but I know that some 7/9T owners have a problem like that if the airbox to turbo hose breaks somewhere.
iamrolling is offline   Reply With Quote
Old 07-31-2020, 05:48 PM   #5
HighMans
Board Member
 
Join Date: Mar 2019
Default

Quote:
Originally Posted by iamrolling View Post
How many miles ago? I only do it every 40-50k and only because so many miles have passed, but I've heard of some turbo car owners having to clean at least the TB every 10k or they start having issues. Look for failed air hoses too. I don't know how your F+T is set up, but I know that some 7/9T owners have a problem like that if the airbox to turbo hose breaks somewhere.

Not even 1000 miles ago lol. Haven't looked under the hood yet -- way too hot, but I will tomorrow. Gonna pull the dizzy out too just to check.
HighMans is offline   Reply With Quote
Old 07-31-2020, 05:53 PM   #6
iamrolling
Board Member
 
Join Date: Nov 2019
Default

Quote:
Originally Posted by HighMans View Post
dizzy
Also might be worth it to pull the spark plug wires off and see if one or more comes off a little too easily.
iamrolling is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 03:26 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.