home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

Reply
 
Thread Tools Display Modes
Old 06-03-2018, 12:20 PM   #26
Chumley360
Board Member
 
Join Date: Oct 2005
Location: Norfolk, VA
Default

Got everything on and the car running again yesterday. Had a DOA new ECT cause starting issues at first. I swapped the old one back in and everything is working again.

I had to scrap my grille plan for the time being so I pealed the poorly applied plasti-coat off to find the chrome plating in crap-tastic condition. I ground it down as smooth as I could, the really bad spots aren't visible with the grille mounted. But there won't be much painting today, it's 100% rain/humidity. I did get the center sash painted though. Just finished up the black stripe, I'll let it dry and see about the next coat. Then it'll get some gloss clear and my prancing moose emblem. also started making a mounting plate for the front RDesign badge.

20180603_120553
__________________
Got boost? Yes! Got manual? Yes! Got gear? Yes! Got V-8 power? No

1995 940t
Chumley360 is offline   Reply With Quote
Old 06-03-2018, 01:48 PM   #27
Chumley360
Board Member
 
Join Date: Oct 2005
Location: Norfolk, VA
Default

And my grille badge bracket. a quick coat of black and it should blend in pretty nicely.

20180603_134216
20180603_134235
Chumley360 is offline   Reply With Quote
Old 06-04-2018, 04:15 PM   #28
Chumley360
Board Member
 
Join Date: Oct 2005
Location: Norfolk, VA
Default

Got the moose badges on the fenders.

20180604_153112
20180604_155555

I'm waiting on all the paint for the grille parts to set. It'll probably be Wednesday before I can get everything back together.
Chumley360 is offline   Reply With Quote
Old 06-08-2018, 03:13 PM   #29
Chumley360
Board Member
 
Join Date: Oct 2005
Location: Norfolk, VA
Default

Well after painting the sash and grille frame a color that matched the wheels and side emblems I ended up not liking it at all. Luckily I has some shadow paint handy and a few coats later I got a charcoal type color that I can live with. And a shot of the "finished" engine bay.


20180607_152657
20180608_143856

Now I just need to get ahead on a few home projects and start building my exhaust system. Then it'll be chips and unless I decide on a 16v swap as my engine choice the engine will be done. I still want to get some sways and I might go with aftermarket springs, but they have more drop than I really want. I think big sways on soft springs with get me there.
Chumley360 is offline   Reply With Quote
Old 06-09-2018, 04:01 PM   #30
InTheWhite
Board Member
 
InTheWhite's Avatar
 
Join Date: Jan 2017
Location: Sweden
Default

Looking good!
InTheWhite is offline   Reply With Quote
Old 06-13-2018, 03:29 PM   #31
Chumley360
Board Member
 
Join Date: Oct 2005
Location: Norfolk, VA
Default

Rear muffler hanger finally rotted through on the way home today. Fun times all around. And I had a brake hose blow off of my Wrangler Saturday, luckily I was just moving cars around the driveway. So I cobbled together a hanger to get me through until I can buy the pipe to run the new stuff. Nothing special, just some 2.5" single muffler w/high flow cat and some tips I got lucky and have a 2.5" down pipe, so at least something is looking up.
Chumley360 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:53 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.