home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 06-05-2018, 05:44 PM   #1
283SD
Board Member
 
Join Date: Mar 2008
Default Cranks no spark, no fuel pump

Drove my wife's 1990 245 into the shop with a check engine light. clearer the code , now it won't start,cranks but will not start. Check engine light does not come on with key in on position. changed the usual parts still no luck
283SD is offline   Reply With Quote
Old 06-05-2018, 06:34 PM   #2
dl242gt
Can play the blues
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

I start at the fuse in the engine compartment. On the inner left fender. It is the main power fuse for the injection and ignition. A bad fuel pump relay can also do this. If the system side of the relay doesn't work you have a no spark no fuel symptom. My 93 recently had a bad fuel pump relay that caused a no spark no fuel. Also fuse twelve is involved in the power up process.
__________________
Dave,
1982 242 turbo. 340k miles. Good stuff and lots of rust.
1993 245 Classic, 420k miles, enem V15. IPD bars and chassis braces. Simons sport exhaust from Scandix. sbabbs ezk chip. Been a good road warrior. Genuine Volvo rebuilt leaky M47.
dl242gt is online now   Reply With Quote
Old 06-05-2018, 08:38 PM   #3
283SD
Board Member
 
Join Date: Mar 2008
Default

Did that, also changed the fuel pump relay and checked all the fuses. the check engine light does not come on with the key on?
283SD is offline   Reply With Quote
Old 06-06-2018, 07:21 AM   #4
283SD
Board Member
 
Join Date: Mar 2008
Default

Found the problem,one of the ground wires for the fuel injectors was loose. The bolt that I thought was tight was binding before it got tight.
283SD is offline   Reply With Quote
Old 06-06-2018, 08:35 AM   #5
ZVOLV
<Master Tech>
 
ZVOLV's Avatar
 
Join Date: Nov 2002
Location: California
Default

Damn fuel injector grounds!!!
__________________
No Start Thread
ZVOLV is offline   Reply With Quote
Old 06-06-2018, 04:18 PM   #6
ZVOLV
<Master Tech>
 
ZVOLV's Avatar
 
Join Date: Nov 2002
Location: California
Default

Quote:
Originally Posted by 283SD View Post
Drove my wife's 1990 245 into the shop with a check engine light. clearer the code , now it won't start,cranks but will not start. Check engine light does not come on with key in on position. changed the usual parts still no luck
I found it very informative that the check engine light wouldn't illuminate. A certain member here calls those grounds "injector grounds." They are the grounds for the ECU, hence no CEL because your ECU has lost its' ground.
ZVOLV is offline   Reply With Quote
Old 06-06-2018, 06:13 PM   #7
283SD
Board Member
 
Join Date: Mar 2008
Default

Drove me crazy for 5 days, it started with a head gasket change, the bolt in question seemed tight but was .010 of contacting the fuel rail, didn't want to break it with more torque on the little bolt. That one ground was the cause of all the problems.
283SD is offline   Reply With Quote
Old 06-06-2018, 07:26 PM   #8
dl242gt
Can play the blues
 
dl242gt's Avatar
 
Join Date: Jun 2002
Location: S NJ, a suburb of Phila.
Default

Good one. Sneaky little ground connections.
dl242gt is online now   Reply With Quote
Old 06-09-2018, 09:47 PM   #9
Mbeas96
Board Member
 
Mbeas96's Avatar
 
Join Date: Aug 2017
Location: Charleston
Default

I found mine stripped when it popped out during a pull, made the car mis like crazy, afrs were all over the place. Retapped and used bigger bolts
__________________
Quote:
Originally Posted by Mr.Bill View Post
You are not a man unless you've thrown up at a turbobricks meet.

My build thread: http://forums.turbobricks.com/showthread.php?t=340910
Mbeas96 is offline   Reply With Quote
Old 06-10-2018, 02:16 AM   #10
283SD
Board Member
 
Join Date: Mar 2008
Default

Car runs great so far, since fix, amazing what one wire will do to the elect system.
283SD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:33 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.