home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

Reply
 
Thread Tools Display Modes
Old 05-06-2019, 08:30 PM   #426
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Well.. It's running like utter doo-doo over ~5psi now. Most of the time. Sometimes it runs perfectly when I mash it. Sometimes it seems to run on 3. Sometimes it back/afterfires violently. I've checked a bunch of connectors and cleaned cap/rotor. Also popped in another MAF. What could cause it to intermittently misfire in boost?



The loud rattling is coins in the ashtray.

EDIT: Well.. I put in a new coil and took it for a test drive. The instant I hit WOT it died. Blown fuse. Replaced it and it still wouldn't start. Eventually I figured out that if I hold one of the contacts in the fuel pump relay halfway while cranking it'll stay running... Tried 2 different relays, no difference. The damn wiring in this car.. Also it now shuts off instantly with the key. Didn't do that before, so that's nice..
__________________
I don't know what I have

Last edited by Cwazywazy; 05-06-2019 at 10:03 PM..
Cwazywazy is offline   Reply With Quote
Old 05-15-2019, 09:30 PM   #427
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Does anyone make a quality sending unit? And what's the general consensus on the URO one? ($61 on Rockauto.) I put in a relay triggered by the FPR to power the pump from the distribution block by the battery with a nice thick wire but while messing with the sending unit wiring it basically crumbled inside the insulation.. Still works since I patched the power wire back together but I'd like to replace it before it breaks again.



Also slapped the condenser back in with a new drier. Holds vacuum so I ordered some Envirosafe.




Also this:



I dunno how accurate it is and the synchro was trying to fight me on the 1-2 shift but I'm pretty happy with a sub-7 second 0 to 60. If it's accurate I'd bet that with a locker axle and a non crappy trans it'd be under 6.

Last edited by Cwazywazy; 05-15-2019 at 09:37 PM..
Cwazywazy is offline   Reply With Quote
Old 05-16-2019, 08:27 AM   #428
Stiggy Pop
Board Member
 
Stiggy Pop's Avatar
 
Join Date: Feb 2011
Location: Granville, MA
Default

That 0-60 time is pretty damn good!
__________________
'79 242
943 pickup
Stiggy Pop is online now   Reply With Quote
Old 05-21-2019, 03:38 PM   #429
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default




A sticker has been installed.




Put in tach and knocksense. Used the lambda light for it. In the wagon I had the led in a switch blank but that was too far away and I didn't really like the look of it. Still need to figure out a speedo solution.. I'd like to get a mechanical speedo overdrive bit since my OD has been steadily going out over the last few years. It used to work at basically any speed but now it really doesn't work unless I'm doing over 60.



AC works now. Not awesomely, but it works. Runs about 50 at the vents with over 80 ambient, more like 45 at 70.



I've also been working on this. I got half of the exhaust studs out but I'm really struggling with the remaining ones.
Cwazywazy is offline   Reply With Quote
Old 05-23-2019, 05:21 AM   #430
John242Ti
LH-Jet & Carb Free Zone
 
John242Ti's Avatar
 
Join Date: May 2003
Location: Duvall, WA
Default

I'd probably go the replacement OD route. Since your car had a 3.31 to begin with, find an OD unit from a 1985 DL or GL. It'll have the correct worm gear and speedo drive gear, plus it'll have the correct length housing for the extension housing on your 1986 box. Messier, yes. But, no brake bleeding necessary.
__________________

1982 242Ti - black, M46. 1985 245Ti - blue, M46. Formerly Blue245Ti, 245GT-Turbo, and, originally 242GT-Ti.
John242Ti is offline   Reply With Quote
Old 05-23-2019, 12:51 PM   #431
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

I think I'm gonna try the electric speedo route, would make things easier if I decided to ditch the Volvo transmission..

Quick question, I found an old gauge cluster in my parts pile with a 120mph mechanical speedo with a couple electric connections on the back of it. What would those possibly be for?
Cwazywazy is offline   Reply With Quote
Old 05-25-2019, 10:23 PM   #432
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Two turbo related failures in one day. Breaking records. Couple days ago I hit a bump pretty hard and cracked the weld holding the V band to the exhaust housing. (Stainless steel welded to cast iron with a flux core...) Earlier today it separated completely and turned into a crappy race car.

Then while I was driving carefully to church, as I always do, the 15g suddenly and totally let go in a massive smokeshow. Thought I was on fire. My quick release ziptie fire extinguisher system worked perfectly, though I didn't actually have to use it.





Cwazywazy is offline   Reply With Quote
Old 05-25-2019, 11:08 PM   #433
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

I paid 75 bucks for that 15g and it barely took, what, two years of abuse? What a ripoff.

Just checked the shaft play and it's the same as it was when I slapped it on so I'm sure it could be rebuilt but I think I'mma just buy the Kinugawa 20t..
Cwazywazy is offline   Reply With Quote
Old 05-27-2019, 11:45 PM   #434
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

I don't think I've mentioned it here, but my goal with this block is to make 300whp on LH2.2 and 93 octane. So I was doing some research on spinny majigs and I decided not to buy the 20t...

I decapitated it (Might as well, needs valve seals and a water pump) and everything looks just as good as when I threw the motor together in 2017, just with more carbon. Also discovered a crack in my uncracked 90+..



EDIT: Oh yeah, the starter motor also died. And one of the windows is stuck down.

Last edited by Cwazywazy; 05-27-2019 at 11:59 PM..
Cwazywazy is offline   Reply With Quote
Old 05-28-2019, 02:26 AM   #435
Sjeng
Board Member
 
Sjeng's Avatar
 
Join Date: Sep 2017
Default

I like your attitude. Having said that, this thing needs a holset without supporting mods.
Sjeng is offline   Reply With Quote
Old 05-29-2019, 09:14 PM   #436
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default



Cwazywazy is offline   Reply With Quote
Old 05-30-2019, 11:13 PM   #437
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

So I bought one of these old school Dremel flexy shafts:



Works really nicely.

Cwazywazy is offline   Reply With Quote
Old 06-01-2019, 12:30 AM   #438
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Head is pretty much ready for assembly. I didn't really make the ports any bigger or anything like that, partially because I don't think there's much benefit in doing that with a stock intake manifold and valves, partially because I don't exactly know what I'm doing. I just got them nice and smooth.





Now I'm just making things pretty while I wait for my turbo to arrive..



EDIT: I also fixed the window. Someone was inside that door before me and they left the motor completely loose.. Explains the noise.

Last edited by Cwazywazy; 06-01-2019 at 01:02 AM..
Cwazywazy is offline   Reply With Quote
Old 06-01-2019, 12:52 AM   #439
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

is your fuel filter mounted right above the down pipe? because if so, thats a fantastic idea
__________________
1979 Volvo 244DL 6.0/4l80e,8.8,Ms3x goldbox ecu and Mircrosquirt tcu, GTX4202r, 228/230cam, tbss intake, 11.4@123mph 9psi
1990 Volvo 245, Efan conversion, tcam, Aw71 FOR SALE
1982 Ford Fairmont Futura. 3sge Beams, j160 6speed, full aje suspension and tubular arms everywhere
1995 Porsche 993
2013 VW Passat TDI
Quote:
Originally Posted by bricktop420 View Post
Thank you very much everybody... i now feel sufficiently retarded and will go cry in the corner...
cosbySweater is offline   Reply With Quote
Old 06-01-2019, 11:37 PM   #440
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by cosbySweater View Post
is your fuel filter mounted right above the down pipe? because if so, thats a fantastic idea
It's okay, I have a fire extinguisher.





Put in new water pump and a thingy to use the front oil port instead of that weepy garbage 3 way fitting for turbo feed. Head is pretty much done with an IPD turbo whatever cam installed.

The old water pump shaft was bent from the accident and it's been making funky noises ever since but it wasn't leaking, so..

Last edited by Cwazywazy; 06-01-2019 at 11:48 PM..
Cwazywazy is offline   Reply With Quote
Old 06-03-2019, 10:09 AM   #441
IansPlatinum
Board Member
 
IansPlatinum's Avatar
 
Join Date: Jul 2018
Location: Texas
Default

Quote:
Originally Posted by Cwazywazy View Post
Time for spring seats bud
__________________
'96 854 Platinum - "Trusty"
'92 245 - "Boat"
'71 145 - "Rusty"
'73 1800es - "Sunny"
IansPlatinum is online now   Reply With Quote
Old 06-03-2019, 02:34 PM   #442
57plymouth
Board Member
 
57plymouth's Avatar
 
Join Date: Jul 2015
Location: Blythewood, SC
Default

Quote:
Originally Posted by IansPlatinum View Post
Time for spring seats bud
No way CwazyWazy spends that kind of money. Nope.
__________________
Sven, the 1991 245
57plymouth is offline   Reply With Quote
Old 06-03-2019, 03:29 PM   #443
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Quote:
Originally Posted by 57plymouth View Post
No way CwazyWazy spends that kind of money. Nope.
They don't make me go faster in a straight line, why bother?

I've got a pile of suspension stuff but I'm leaving it stock for now. I like the comfort. Eventually I plan on putting in all my goodies with new bushings, maybe lower it just a little.

According to the website my turbo hasn't shipped yet and the customer support stopped replying to me.. I was hoping on making it to Lime Rock but I don't think that's happening. Maybe I could write Volvo on the Galaxie..
Cwazywazy is offline   Reply With Quote
Old 06-06-2019, 09:56 PM   #444
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Well I got bored of waiting for my new turbo and figured out how to give my 15g a complete $0 rebuild using parts from my obliterated 19t. It now has zero shaft play. I'm also proud of my new oil feed solution, using no zipties. Clears perfectly fine with the Denso alt.

It runs and drives fine.. Except I think it's slower than it was two weeks ago, especially in the lower part of the rev range. I was expecting that with the IPD cam but I was also expecting it to pull harder up top.. Maybe the log manifold is a lot worse than I thought, though I don't remember noticing a real difference when I upgraded to the 90+ on the wagon.

I also spent some time fixing all the little wiring problems that I either ignored or temporarily repaired. Looks a lot nicer without my makeshift injector harness I made back in January.

Currently at ~12 degrees base timing with .035" plug gaps and about 15psi. I'll have to play around with the cam timing.






I don't like the breather hose. I think I'm gonna try and make a pretty one out of some hardline and P clip it on top of the oil line.

I put valve hushers in it while I was in the head. I almost miss the sewing machine noise now..

EDIT: Also it took like 20 miles for all the oil to burn off my downpipe. People looked at me funny. After that 20 miles it didn't smoke at all or drip anything but AC water.

Last edited by Cwazywazy; 06-06-2019 at 10:02 PM..
Cwazywazy is offline   Reply With Quote
Old 06-08-2019, 01:40 AM   #445
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Cwazywazy is offline   Reply With Quote
Old 06-09-2019, 03:54 PM   #446
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

It's definitely slower than the wagon was, but also more fun. Only failure yesterday was my rear passenger window getting stuck down again.. Not sure exactly what, but something in the mechanism got bound up and removing/reinstalling the motor freed it up. Engine pulls right up to the limiter instead of the power dropping off, which I like.





Rate my one wheel peel action.

I think cleaning up all the carbon helped to reduce knock. Before it'd ping a little bit if I ran it hot and hard but now (With another 2 degrees timing, same boost) it doesn't ping at all. Even going WOT with the temp needle nearly in the red.. Radiator fan needs a little work.

Last edited by Cwazywazy; 06-09-2019 at 04:00 PM..
Cwazywazy is offline   Reply With Quote
Old 06-14-2019, 02:58 PM   #447
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default




Cwazywazy is offline   Reply With Quote
Old 06-15-2019, 01:09 PM   #448
Sjeng
Board Member
 
Sjeng's Avatar
 
Join Date: Sep 2017
Default

Is that a TD05?
Sjeng is offline   Reply With Quote
Old 06-15-2019, 09:52 PM   #449
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Yup, TD05 20g.






At wastegate pressure right now (15psi) and the only issue is that it came with a blowoff thing instead of a CBV and it's open at idle/cruise making it run rich. Hits full boost by 3 grand.

I did some other little things like fix the big gap between the radiator and the fan. I replaced the slightly too short original nylon fuel feed hose with a 6an nitrous line. I like it cause it looks pretty.



Cwazywazy is offline   Reply With Quote
Old 06-15-2019, 10:52 PM   #450
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default

Swapped over the CBV from the 15g and now it runs great except it seems to have developed a soft rev limiter at 5500. Pretty sure my intake hose is getting sucked shut now.

Cwazywazy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:42 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.