home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > performance & modifications

Reply
 
Thread Tools Display Modes
Old 04-26-2019, 02:43 PM   #51
VB242
A tough rowing ho
 
VB242's Avatar
 
Join Date: Sep 2011
Location: Virginia Beach
Default

If you switch to speed density/megasquirt you don't need a maf at all.
__________________
1980 Richelieu red JDM flares franken-242DL now with 8.8, 1989 silver 780 sienna rear spring nivomat delete.
VB242 is offline   Reply With Quote
Old 04-29-2019, 02:38 AM   #52
Brotkasten
Jonas
 
Brotkasten's Avatar
 
Join Date: Aug 2017
Location: Wolfsburg, Germany
Default

Quote:
Originally Posted by Cwazywazy View Post
Can't you just put the MAF after the turbos or does that not work with LH?
That works quite well actually. Ran it for 6 months without an issue.
__________________
91' 940 B230FB+T M90
Brotkasten is offline   Reply With Quote
Old 05-03-2019, 12:40 PM   #53
Swedbrick
Board Member
 
Swedbrick's Avatar
 
Join Date: Oct 2016
Location: Netherlands
Default

Interesting, moving the MAF(s) would open up some options and allow me to get them away from the turbo manifold. Thanks for the tip!

My current plan was to first get the base map worked out on the car with the itb's (in an airbox) whilst also moving on with the turbo stuff on the engine stand. With a blow trough setup I could also keep the same wiring then.

After that I was planning to put the new engine in, and run it in without the turbo's after which I can start to add all of the complex bits for the TT setup and make it work. And then slowly increase the boost until I am where I wish to be power wise.

Sorry for the lack of actual updates for now, with the current study load I can only get to benchracing an a little progress each week

Oh and additionally, I finally got my eeprom programmer and eeproms, so soon I'll be trying to burn a couple of chips
__________________
Volvo 745 - IPD springs, Sways, K-cam, LH2.4, M90 swap, 3.94 diff, track/daily
Swedbrick is offline   Reply With Quote
Old 06-03-2019, 03:41 PM   #54
Swedbrick
Board Member
 
Swedbrick's Avatar
 
Join Date: Oct 2016
Location: Netherlands
Default China intercoolers, put the head on, and got myself into 16v trouble

Finally some more progress on both the engine and the car itself, with some late nights and little tasks during quick study breaks

The first hurdle was cleared by drilling out the old oil pump drive gear, and installing a new one, with the installer made by a friend. These were only available from Volvo Penta, so I took the liberty of getting 2 at once for possible future projects.


The next hurdle, the intermediate shaft bearings was also cleared. I covered the new bearings in a good inside coating of vaseline top prevent gaulling of the surface, and used a m20 threaded rod to pull in the bearings nice and straight, finally they are in perfect


Youtube video for the fit:p


I also put in the rear oil seal in one go, so much win!


A few days later I spent a day porting, polishing and reassembling the oil pump, all should be well.













Moving back to the engine itself, I got the head installed with the 12.9 grade head bolts, and proceeded to spend ages to get the valve shims in spec (6 attempts required for perfection):p











With the valve clearance set, I proceeded to applying anaerobic sealant to the cam end caps and put in the rear and front cam seal, since I'll be going wasted spark with this setup.






The large intercoolers I ordered also arrived at the post office, hopefully they'll fit in the front with my measurements.


With all except the oil pan sorted, I proceeded to time the motor on the stand.


And discovered an issue with my plan to use a 24mm wide timing belt.


After a little read and contact with KGtimmning, I went on the lookout for 16v cam gears, which escalated into me buying a set of PZ 16v cams, the roller and belt for a 16v conversion for Strettman. Who I ended up helping to buy a very clean orange 242 which was local to me, pretty cool coincidence.


The crankshaft gear had a little damage on the key, which I managed to restore with a weld bead and a file to an acceptable result.


With this the issue was partly solved, more updates on getting a fitting timing cover and tensioner later.

Proceeding with a night of playing around with the welder and grinder I also managed to create v2 of half of the turbo manifold, which after a test fit on the car still required some adjustments, since my initial placement for turbo #2 was in the frame rail. Stupid mistake, but I modeled it without the car in winter in the driveway to check, so it was to be expected.


I'll soon be getting test fitting v2.5 to continue with the top manifold for turbo #2 (fitment will be different, but this should give an idea of the interfering framerail
Swedbrick is offline   Reply With Quote
Old 06-03-2019, 03:47 PM   #55
Cwazywazy
Single jingle
 
Cwazywazy's Avatar
 
Join Date: Aug 2016
Location: Granby CT
Default



Backwards? Black side faces out, pretty sure..
__________________
I don't know what I have
Cwazywazy is offline   Reply With Quote
Old 06-03-2019, 04:16 PM   #56
Harlard
80/20 speed parts club
 
Harlard's Avatar
 
Join Date: May 2007
Location: PDX
Default



You may have to re-engineer your coolant transfer tube with that manifold.
__________________


Herr Harlard am Erstens

1979 242 DL

Quote:
Originally Posted by t8fanning View Post
My knob has a big chunk of steel on it
Harlard is offline   Reply With Quote
Old 06-03-2019, 04:54 PM   #57
Swedbrick
Board Member
 
Swedbrick's Avatar
 
Join Date: Oct 2016
Location: Netherlands
Default

Quote:
Originally Posted by Cwazywazy View Post

Backwards? Black side faces out, pretty sure..
Hmm, probably then, seemed the most logical at the time, but rubber on the oil side is maybe less smart. I'll change it out by the time I've gone through run in and am ready to put my K-cam in Thanks!


Quote:
Originally Posted by Harlard View Post

You may have to re-engineer your coolant transfer tube with that manifold.
Yes I already noticed indeed, with a little adjustment it should work however, I'm more concerned as to the turbo not hitting my strut towers
Swedbrick is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:27 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.