home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-11-2015, 04:30 AM   #11
peterwgpa
Board Member
 
peterwgpa's Avatar
 
Join Date: Dec 2011
Location: Australia
Default

Tune up and wheel alignment done. She now runs sweetly. Ended up fitting a brand new fuel pump and accumulator as it was not holding pressure and the pump was at end of its life. Both were the items from one of the donors and were the only 2 items in fuel delivery system not renewed already. Line pressure was just not good enough. They had been sitting unused for around 5 years.

Had to adjust reverse lock out and have pulled the overdrive wiring from the shifter. Overdrive will not be needed for local tracks and we are going to use a switch on dash to operate. Will sort out when we get a spare half an hour well before it will be needed.

Loaded up for a track test next week so fingers crossed we have it all sorted for a decent shake down.

Will put up some photos from track test day
peterwgpa is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:44 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.