home register FAQ memberlist calendar

Go Back   Turbobricks Forums > General > showroom

Reply
 
Thread Tools Display Modes
Old 04-13-2019, 09:57 PM   #1
TeamTFR
Board Member
 
TeamTFR's Avatar
 
Join Date: Mar 2008
Location: Hagerstown, MD
Default 90 +t 240

Recently picked up this +t 244, thought some of you may recognize it.

b230f+t, m47, 15g, Npr intercooler, 3 inch exhaust, A cam, etc. Has various suspension mods including an uhh...interesting spring and strut setup including Toyota struts that don't actually fit giving it self adjusting camber while driving

So far I've replaced the wheels, fuel line (it had dish washer hose from the tank to the filter), driver's seat, ecu and ezk, and replaced the bov with pipe/reinstalled the recirc valve. Just bought Bilstein hd's for it but need to find some factory springs before putting them in.

Also have a WC t5 trans from a foxbody waiting for when the m47 gives up.





__________________
Current-
17 Regal Turbo
90 244 +T
89 245
TeamTFR is offline   Reply With Quote
Old 04-14-2019, 12:21 AM   #2
LC4CARL
Aero challenged
 
LC4CARL's Avatar
 
Join Date: Sep 2008
Location: Portland, OR
Default

On the wagon. Are the rear headrests a pain to see around? Thx.
__________________
Built-not-bought: PDXdl Resto-Mod - B21FT / M47.
Quote:
Originally Posted by Redwood Chair View Post
Life begins at 10PSI.
LC4CARL is offline   Reply With Quote
Old 04-14-2019, 12:42 PM   #3
TeamTFR
Board Member
 
TeamTFR's Avatar
 
Join Date: Mar 2008
Location: Hagerstown, MD
Default

They aren't too bad really. That car spends most of its time with the seat folded down hauling stuff though
TeamTFR is offline   Reply With Quote
Old 04-14-2019, 01:00 PM   #4
towerymt
the real Towery
 
towerymt's Avatar
 
Join Date: Sep 2002
Location: VA, USA
Default

Looks familiar





It was n/a and LH3.1 when I sold it. 100% reliable for 3 years, having zero breakdowns. Great car...but ugly paint...and slow.
towerymt is offline   Reply With Quote
Old 04-14-2019, 09:56 PM   #5
TeamTFR
Board Member
 
TeamTFR's Avatar
 
Join Date: Mar 2008
Location: Hagerstown, MD
Default

I know that it's been around here for a while now. It pretty much has broken every time I've driven it but I'm slowly getting it all taken care of.

I'm hoping to have Virgos on it here soon. Planning on painting it over the summer as well and hopefully e codes and new tail lights.
TeamTFR is offline   Reply With Quote
Old 04-15-2019, 08:29 AM   #6
soclosenotnear
Board Member
 
Join Date: Oct 2011
Location: summerville, south carolina
Default

Quote:
Originally Posted by TeamTFR View Post
I'm hoping to have Virgos on it here soon. Planning on painting it over the summer as well and hopefully e codes and new tail lights.
That'll be a new lease on life. Good luck.
soclosenotnear is offline   Reply With Quote
Old 04-15-2019, 02:38 PM   #7
towerymt
the real Towery
 
towerymt's Avatar
 
Join Date: Sep 2002
Location: VA, USA
Default

How many miles on it now? It got a new Hepu water pump around 160k, plus timing belt & tensioner, one front seal (cam? one was dry, one got replaced).
towerymt is offline   Reply With Quote
Old 04-15-2019, 03:01 PM   #8
woodenpudden
lacks goats
 
woodenpudden's Avatar
 
Join Date: Sep 2005
Location: Princess Anne, MD
Default

circa 2009

__________________
Quote:
Originally Posted by DMFWallace View Post

Flunt delivers!
woodenpudden is offline   Reply With Quote
Old 04-15-2019, 11:19 PM   #9
TeamTFR
Board Member
 
TeamTFR's Avatar
 
Join Date: Mar 2008
Location: Hagerstown, MD
Default

Quote:
Originally Posted by towerymt View Post
How many miles on it now? It got a new Hepu water pump around 160k, plus timing belt & tensioner, one front seal (cam? one was dry, one got replaced).
Cluster says 212k, I was told that at 195k the odometer broke and the cluster was swapped for one that had 210k at the time
TeamTFR is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:52 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.