home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 12-28-2012, 04:54 PM   #1
yorkadam
Board Member
 
Join Date: Dec 2012
Location: East Lansing, MI
Default Bad reverse switch harness - diagram needed

I've got a 1983 volvo 245 turbo, manual transmission conversion...and the reverse lights don't work.

So I jacked/standed the car and tested the wiring AND reverse switch. After much swearing I managed to test everything...I now get the 'small hands help' comments.

Test results:

switch on transmission - OK
wiring harness from transmission to ?? - BAD/weak
reverse bulb - OK
bulb connection in the tail light - OK
Fuse & voltage - OK

So as best I can tell the wiring harness from the transmission to the ?relay? is bad...or maybe the relay is bad? Does anyone have diagrams of where the wire harness or relay are located?
yorkadam is offline   Reply With Quote
Old 12-28-2012, 06:25 PM   #2
vlvman
Board Member
 
vlvman's Avatar
 
Join Date: Mar 2009
Location: Jefferson City, MO
Default

Check the site in my signature.
__________________
Robert
http://www.volvowiringdiagrams.com/
82 244DL, 2004 S60R AWD, 2008 S40 GF's
Had: 77 242 DL, 80 242 DL, 82 245 DL, 89 740 GL, 94 850T, 95 850 GL, and a 02 S60 2.4T
vlvman is offline   Reply With Quote
Old 12-28-2012, 06:44 PM   #3
Mylesofsmyles
Board Member
 
Join Date: Jan 2010
Default

There is no relay for that.

The wire from the trans switch goes right back to the lights
Mylesofsmyles is offline   Reply With Quote
Old 12-28-2012, 08:34 PM   #4
yorkadam
Board Member
 
Join Date: Dec 2012
Location: East Lansing, MI
Default

Funny - after looking at the diagram my time cursing under the car was pointless. You can diagnose it from inside the car with the wire harness connector that comes from the floor and goes into the dash. Oops.

Appears to be faulty somewhere between the connector (H in diagram) and the tail light...I'll need more wires to be able to test the entire length of the circuit.


yorkadam is offline   Reply With Quote
Old 12-28-2012, 08:49 PM   #5
vlvman
Board Member
 
vlvman's Avatar
 
Join Date: Mar 2009
Location: Jefferson City, MO
Default

I bet it is at the tail lights, check for power at the left tail light harness first.
vlvman is offline   Reply With Quote
Old 12-28-2012, 09:15 PM   #6
yorkadam
Board Member
 
Join Date: Dec 2012
Location: East Lansing, MI
Default

I played the wire swap game on the rear tail light. The bracket and bulb work.

The issue is between the wire that goes to the left tail light and the ignition switch. I'll need some extra wire to see on which side of the harness connector (H) it is. There is an added complication with a remote lock system wired into the mix.
yorkadam is offline   Reply With Quote
Old 05-08-2013, 12:20 PM   #7
yorkadam
Board Member
 
Join Date: Dec 2012
Location: East Lansing, MI
Default

Last update: Apparently volvo ran part of the wiring from the fuse panel to the transmission switch under the drivers feet somewhere. That wire was broken though the rest of the wiring to the tail light, switch, and ignition were good. I simply ran a new wire UP under the dash to get the power to the reverse switch.
yorkadam is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 02:49 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.