home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Search Forums

Showing results 1 to 6 of 6
Search took 0.00 seconds.
Search: Posts Made By: dl242gt
Forum: maintenance & nonperformance 09-24-2022, 12:31 PM
Replies: 20
Views: 3,271
Posted By dl242gt
Yes, I have used this several times. It looks...

Yes, I have used this several times. It looks amazing if you like electricity. I even
found a plug wire that was arcing through the boot to the head using this method.
Forum: maintenance & nonperformance 09-20-2022, 01:10 PM
Replies: 20
Views: 3,271
Posted By dl242gt
Have you checked the distributor cap for cracks?...

Have you checked the distributor cap for cracks? They can be very small and hard to find. It also may be good to check the resistance of the plug wires.
Forum: maintenance & nonperformance 09-03-2022, 06:50 PM
Replies: 20
Views: 3,271
Posted By dl242gt
I think the name of the place was Tool Source....

I think the name of the place was Tool Source. Here it is. I admit I haven't used
it yet as my car has the shrader valve in the fuel rail. Terrible photo but it's
cheap enough to try....
Forum: maintenance & nonperformance 09-03-2022, 06:45 PM
Replies: 20
Views: 3,271
Posted By dl242gt
You need a an adapter fitting to go between the...

You need a an adapter fitting to go between the feed line and the rail. There was an old thread about the fitting you can buy from Pro Tool. Something like 'LH2.4 adapter fitting' should find the old...
Forum: maintenance & nonperformance 08-13-2022, 06:09 PM
Replies: 20
Views: 3,271
Posted By dl242gt
You can remove fuse 4 or 5 depending on the year....

You can remove fuse 4 or 5 depending on the year. Then connect your amp meter across the fuse tabs. That current reading will tell you if the pump is running. Usually, about 1.7-2 amps for the stock...
Forum: maintenance & nonperformance 08-13-2022, 06:08 PM
Replies: 20
Views: 3,271
Posted By dl242gt
Are you sure the pump is running? Because I've...

Are you sure the pump is running? Because I've experienced the ground tab on the sender failing. Then the pump doesn't run. To fix that you have to drill a small hole in the sender and crimp a ring...
Showing results 1 to 6 of 6

 
Forum Jump

All times are GMT -4. The time now is 12:09 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.