View Single Post
Old 11-23-2021, 01:31 PM   #2
oldnfast
Board Member
 
Join Date: Feb 2011
Location: connecticut
Default

Quote:
Originally Posted by noz-e8tr View Post
Help me....I'm running out of ideas.
This is a N/A Rex/Regina, so we are looing at an air intake temp sensor and MAP sensor. No MAF Sensor. At idle its sickly rich. If I idle for 5+ minutes it starts to load up like a carbed car dumping fuel. It starts to stumble and I have to put it in neutral and rev to clear it out. The gas smell from the exhaust has every one hating me. Here is what has been done.

New O2 Sensor
New MAP Sensor
New Intake Air Temp sensor
New ECU Temp sensor
New Injectors (reconditioned)
New Fuel Pressure Regulator
I've verified correct vacuum at idle to make sure exhaust is not clogged (will mess up a map sensor reading)
I adjusted Throttle Position sensor (but have not replaced it)

My MPG is 20-22 in town, so it seems to predominantly be at idle. Idle does bounce around slightly as if a small vac leak is present, but I have yet to find it (could also be a result of inconsistent fuel). Usually a vac leak in the MAP will cause them to run lean unless the leak is on the MAP circuit...it is not. I'm throwing no check engine codes either.

Not sure if this one has a cold start injector. But that is what I'm checking next. Perhaps the injector is leaking a bit. Anyone got any other ideas? I'm really running out of them myself.
I believe Volvo has a TSB to eliminate the cold start valve on the Regina. I just looked quick but couldn’t find it. Maybe on brickboard, I’ll keep looking
oldnfast is offline   Reply With Quote