View Single Post
Old 11-22-2021, 06:32 PM   #1
noz-e8tr
Board Member
 
noz-e8tr's Avatar
 
Join Date: Aug 2003
Location: Ocean Springs, MS
Default 93 940 N/A (Rex/Regina) Very Rich at Idle

Help me....I'm running out of ideas.
This is a N/A Rex/Regina, so we are looing at an air intake temp sensor and MAP sensor. No MAF Sensor. At idle its sickly rich. If I idle for 5+ minutes it starts to load up like a carbed car dumping fuel. It starts to stumble and I have to put it in neutral and rev to clear it out. The gas smell from the exhaust has every one hating me. Here is what has been done.

New O2 Sensor
New MAP Sensor
New Intake Air Temp sensor
New ECU Temp sensor
New Injectors (reconditioned)
New Fuel Pressure Regulator
I've verified correct vacuum at idle to make sure exhaust is not clogged (will mess up a map sensor reading)
I adjusted Throttle Position sensor (but have not replaced it)

My MPG is 20-22 in town, so it seems to predominantly be at idle. Idle does bounce around slightly as if a small vac leak is present, but I have yet to find it (could also be a result of inconsistent fuel). Usually a vac leak in the MAP will cause them to run lean unless the leak is on the MAP circuit...it is not. I'm throwing no check engine codes either.

Not sure if this one has a cold start injector. But that is what I'm checking next. Perhaps the injector is leaking a bit. Anyone got any other ideas? I'm really running out of them myself.
__________________
1983 242 v8 (aka Berserker)
1985 740 Jurbo
1990 740 Turbo (daily driver)
1993 945 n/a slow as caca.

Berserker 242 Build Thread

Quote:
Originally Posted by Lando View Post
This subculture is not conducive to meeting women let alone inspiring them to drive 30 year old, rectilinear, underpowered shit boxes.
Quote:
Originally Posted by Walt Disney
"All our dreams can come true, if we have the courage to pursue them."

Last edited by noz-e8tr; 11-22-2021 at 07:04 PM..
noz-e8tr is offline   Reply With Quote