View Single Post
Old 05-14-2022, 04:53 PM   #1
atomicdeathmonkey
Board Member
 
atomicdeathmonkey's Avatar
 
Join Date: Jan 2009
Location: Ireland/Korea/Texas
Default The problem with Prv's

Had to make another thread for this one as I'm ruining my original one with all the other vvos I pickup while building my 242 turbo.


Picked up this non running 1981 262c a few months back and started in on trying to resurrect it!

So far it's one step forward ten steps back !

I've replaced the main fuel pump, tank is clean, tank pump working, new fuel filter, fuel injectors are clean, fuel distribution unit seems to be working (depressing the air metering plate it springs back immediately,indicating the valve is moving freely).

Fresh plugs too!

She's running on starting fluid so I think the timing is ok.

Put some 108 octane into it last night with some premium and nowweve lost spark, think I've lost the ignition control unit now any pointers?
Attached Images
File Type: jpeg tapatalk_-776868851_504x283.jpeg (124.2 KB, 177 views)
File Type: jpeg tapatalk_1285607034_504x283.jpeg (123.7 KB, 176 views)
File Type: jpeg tapatalk_-427590251_504x283.jpeg (136.5 KB, 176 views)
File Type: jpeg tapatalk_866835193_283x504.jpeg (133.4 KB, 174 views)
File Type: jpeg tapatalk_551667303_504x283.jpeg (105.5 KB, 176 views)
__________________
Volvo 242 turbo intercooler 1984, 1993 244 auto, w124 300d, toyota big fridge, small toyota washing machine.

Last edited by atomicdeathmonkey; 05-14-2022 at 05:03 PM..
atomicdeathmonkey is offline   Reply With Quote