home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 11-07-2022, 10:58 PM   #1
okoye
Board Member
 
okoye's Avatar
 
Join Date: Jul 2009
Location: Orlando
Default 1995 940 Na to b230FT swap no start

So I've got a 1995 Volvo 940 non turbo that I've swapped to Turbo (complete motor) that I'm having issues getting started. I've changed radio suppression relays, I've changed crank sensors, I've tested for spark (which I have) I jumped the pump to send fuel to the rail. Still wont start.
Any suggestions?

does anyone have pics of their RSR wiring for a 95? I can find pics for the older ones but nothing for the newer 95. I need this car started ASAP
__________________
1991 Volvo 940se sedan m90 swapped, 17x10 oz fittistars, Bilsteins.
1994 Volvo 960 turbo b204ft m46

Quote:
Originally Posted by vagabond View Post
no one saw me with my little umbrella and sandpaper though.
okoye is offline   Reply With Quote
Old 11-07-2022, 11:05 PM   #2
apachechef
Burnt Sierra Madre
 
Join Date: Jan 2009
Location: An obscure body in the SK system
Default

resistor pack?
__________________
Quote:
Originally Posted by lummert View Post
Dammit, Lummert.
Quote:
Originally Posted by Jesse8931 View Post
Well keep us updated on how your dumbass plan goes.
apachechef is offline   Reply With Quote
Old 11-07-2022, 11:12 PM   #3
okoye
Board Member
 
okoye's Avatar
 
Join Date: Jul 2009
Location: Orlando
Default

No resistor pack I’m running injectors from a fwd model
okoye is offline   Reply With Quote
Old 11-07-2022, 11:28 PM   #4
bobxyz
Board Member
 
bobxyz's Avatar
 
Join Date: Aug 2014
Location: Boulder CO
Default

Did you touch the timing belt or distributor during the swap?

You can still find the Mitchell's wiring diagram at https://web.archive.org/web/20160320...ing%20Diagrams
bobxyz is offline   Reply With Quote
Old 11-07-2022, 11:31 PM   #5
okoye
Board Member
 
okoye's Avatar
 
Join Date: Jul 2009
Location: Orlando
Default

If I remember correctly the distributor on a head mount does not affect the timing but I could be wrong
okoye is offline   Reply With Quote
Old 11-07-2022, 11:32 PM   #6
Mylesofsmyles
A Member
 
Join Date: Jan 2010
Default

Here's some info on the Radio Suppression Relay, and led me to figure out how to bypass it during a diagnosis like yours.

https://volvoforums.com/forum/volvo-...y-74098/page2/

You have spark...is it a strong spark?
Have you thrown some starting fluid at to see if it'll run?
Do you have power to your fuel injectors when cranking? Noid light?
Does your motor have compression?
Mylesofsmyles is offline   Reply With Quote
Old 11-08-2022, 12:01 AM   #7
white855T
Board Member
 
Join Date: Sep 2013
Location: Dallas,TX
Default

I would guess the wiring is shot on the rsr and its not letting the injectors fire. Very common issue.
white855T is offline   Reply With Quote
Old 11-08-2022, 09:59 AM   #8
ZVOLV
<Master Tech>
 
ZVOLV's Avatar
 
Join Date: Nov 2002
Location: California
Default

Test lamp and starting fluid. Click my sig.
__________________
No Start Thread
ZVOLV is offline   Reply With Quote
Old 11-08-2022, 10:47 AM   #9
lookforjoe
Making Volvo Parts Fit
 
lookforjoe's Avatar
 
Join Date: May 2008
Location: Rockland County, NY
Default

Does it smell like it's getting fuel? Did you crack the line at the rail after cranking?
What about the ECU? Is it know good from a running vehicle? You can always plug in the NA ECU just to test start...
__________________

My XR July2013 - 446AWHP @ 8K rpm C30 AWD conversion 740 pickup thread Feedback Thread
lookforjoe is online now   Reply With Quote
Old 11-10-2022, 02:33 PM   #10
okoye
Board Member
 
okoye's Avatar
 
Join Date: Jul 2009
Location: Orlando
Default

Does anyone have pictures of a 1995 940 radio suppression relay?
okoye is offline   Reply With Quote
Old 11-10-2022, 02:45 PM   #11
2manyturbos
Moderator
 
Join Date: Mar 2003
Location: Monroe, OR USA
Default

IIRC, the NA 940s do not have a RSR.
2manyturbos is offline   Reply With Quote
Old 11-10-2022, 08:19 PM   #12
bobxyz
Board Member
 
bobxyz's Avatar
 
Join Date: Aug 2014
Location: Boulder CO
Default

If you go back further in time, the Wayback Machine also has a '95 greenbook TP3908202 940 1995 Wiring Diagrams.pdf
https://web.archive.org/web/20131105...ing%20Diagrams
(note: some pages aren't scanned; the 94 greenbook may be better)

pdf pg 13 shows the NA RSR relay, part 2/12, and the fuel injection relay, part 2/23.
pdf pg 14 shows the Turbo RSR relay, part 2/12, and the fuel injection relay, part 2/13.
pdf pg 7 shows the RSR locations in the engine compartment (left NA or right turbo)

The relay itself is weird rectangular box with an offset connector and 4 round pins - I think it's this one
bobxyz is offline   Reply With Quote
Old 11-10-2022, 08:28 PM   #13
lookforjoe
Making Volvo Parts Fit
 
lookforjoe's Avatar
 
Join Date: May 2008
Location: Rockland County, NY
Default

Quote:
Originally Posted by okoye View Post
Does anyone have pictures of a 1995 940 radio suppression relay?
So - it appears to be identical to every other year suppression relay - what made you think it was different for the '95? Do you have a pic of what you're looking at?
lookforjoe is online now   Reply With Quote
Old 11-11-2022, 02:42 AM   #14
okoye
Board Member
 
okoye's Avatar
 
Join Date: Jul 2009
Location: Orlando
Default

So the wiring colors on the rsr is different than earlier models.
I found out the issue was that the ecu I was using was not priming the pumps with key on. I swapped for an earlier lh2.4 turbo ecu and the car fired up. I've got a few more things to sort out namely a clutch fan and some other odds and ends
okoye is offline   Reply With Quote
Old 11-11-2022, 01:11 PM   #15
Mylesofsmyles
A Member
 
Join Date: Jan 2010
Default

Glad you got it running!
Mylesofsmyles is offline   Reply With Quote
Old 11-14-2022, 04:05 PM   #16
okoye
Board Member
 
okoye's Avatar
 
Join Date: Jul 2009
Location: Orlando
Default

Yeah but now I’m having issues almost as if the car is cutting fuel/ spark
okoye is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 08:44 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.