home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 01-15-2020, 07:59 PM   #1
dobber13
Board Member
 
Join Date: Nov 2002
Location: elgin s.c. 29045
Default Poor running when cold

1985 240ti B21ft, When cold the engine will stumble around 2500 rpm's but when idling it runs fine. After the engine is warmed up there isn't a problem.
Could it be the temperature sensor?
__________________
Charlie 85 244 TI B21FT 265K M46
dobber13 is offline   Reply With Quote
Old 01-15-2020, 08:35 PM   #2
hiperfauto
Board Member
 
hiperfauto's Avatar
 
Join Date: Nov 2011
Location: So Cal
Default

Check the cold running enrichment system. The thermal vacuum switch is a likely suspect. It should flow between the ports when cold and close when warm.
hiperfauto is online now   Reply With Quote
Old 01-16-2020, 12:06 AM   #3
dobber13
Board Member
 
Join Date: Nov 2002
Location: elgin s.c. 29045
Default

I will have to look at that this weekend.
Thanks
dobber13 is offline   Reply With Quote
Old 01-16-2020, 12:28 AM   #4
2 old for this
Board Member
 
Join Date: Mar 2018
Location: Amarillo
Default

What does the injector pattern look like?
2 old for this is offline   Reply With Quote
Old 01-16-2020, 11:16 AM   #5
dobber13
Board Member
 
Join Date: Nov 2002
Location: elgin s.c. 29045
Default

Quote:
Originally Posted by 2 old for this View Post
What does the injector pattern look like?
The injectors are not the problem.
dobber13 is offline   Reply With Quote
Old 01-16-2020, 09:06 PM   #6
dobber13
Board Member
 
Join Date: Nov 2002
Location: elgin s.c. 29045
Default

Quote:
Originally Posted by hiperfauto View Post
Check the cold running enrichment system. The thermal vacuum switch is a likely suspect. It should flow between the ports when cold and close when warm.
I tested the thermal vacuum switch and I can't blow through it. Would you have the PN and how much they cost?
dobber13 is offline   Reply With Quote
Old 01-16-2020, 09:20 PM   #7
hiperfauto
Board Member
 
hiperfauto's Avatar
 
Join Date: Nov 2011
Location: So Cal
Default

https://www.tascaparts.com/oem-parts...-valve-1269355
hiperfauto is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 12:32 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.