home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-05-2021, 04:44 PM   #1
bobman360
Newbie
 
Join Date: Oct 2020
Default 85 240 Strange Knocking Issue

Hey! First post here, I promise I've read a lot of stuff and searched around and can't seem to find a situation very similar. Car is an auto wagon with 205k. Recently it has started knocking really loud (afraid it is rodknock or similar mechanical problem) but only when in gear. It seems to have trouble staying running as well. I replaced the knock sensor as it was damaged but this has had no effect. Pulled the plugs and #4 has some white deposits. I also did a compression test which has to be the most confusing part yet.
Cyl 1. 160
Cyl 2. 180
Cyl 3. 112
Cyl 4. 110
I unplugged the maf while the car was running and it worsened the issue so I believe that eliminates the maf as a possible suspect? (Sorry if it's not called a maf, you know what I mean)
The car had some knocking and overheating issues last summer but I replaced the radiator and the cracked intake manifold gasket at that time and it seemed to solve the problem.
bobman360 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:39 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.