home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 08-24-2010, 01:07 AM   #1
Ninja007
Board Member
 
Join Date: Mar 2009
Location: Lynnwood WA
Default Kickdown cable adjustment problems

Hi, after my fresh rebuild I went for my first drive. Everything was functioning properly until I gained a little confidence and pushed the gas pedal further. I broke my kickdown cable because it was adjusted improperly. I since installed a new kickdown cable and CANNOT get it adjusted correctly. I read all the guides on how to do this properly, listened for the click in the trans where the cable should rest etc.

The problem is, if I adjust the cable properly, then extend the throttle body to full open the travel of the cable is maxed out before I hit the stop on the throttle body (this is how my first cable broke). So right now I am forced to leave the kickdown cable with enough slack so that I reach max kickdown at full throttle, however this leads to the trans shifting WAY to early. Very annoying for my DD. Any thoughts on a fix for this? I have thought about moving the stop back on my throttle body, but then I wont be letting the max amount of air into the motor
Ninja007 is offline   Reply With Quote
Old 01-09-2012, 01:29 PM   #2
Ninja007
Board Member
 
Join Date: Mar 2009
Location: Lynnwood WA
Default

Bump. A year later I am still having problems. I have considered cutting the cable by the throttle body and welding a spring inline so it has a bit more travel
Ninja007 is offline   Reply With Quote
Old 01-11-2012, 03:48 AM   #3
project volvo
spoolakowski
 
project volvo's Avatar
 
Join Date: May 2005
Location: from Burlington now Farmington,CT
Default

it sounds like it's maladjusted or the bracket is bent or something. there has to be a particular fault if you have had two different cables but the same issue. Take a look at another car and try to see whats going on. BTW you said you had a fresh rebuild any chance you put a different trans in? aw70 wold shift earlier than an aw71
__________________
SIG


project slowski (old project now gone)^^^

New Project Slug Works


my feedback thread here > FEEEEDBACK!!!!
project volvo is offline   Reply With Quote
Old 01-11-2012, 09:20 PM   #4
DurableSwedish
Hunting for a turbo
 
DurableSwedish's Avatar
 
Join Date: Dec 2003
Location: Hillsboro, OR
Default

how old is the kickdown cable? we just replaced one here at the shop because the end was bent a tiny bit and causing the 940 to shift weird.
__________________
One Volvo left.
1982 244ti (313chp), 2020 Nissan Leaf daily driver, 86 Yugo GV junk pile/gambler car
DurableSwedish is offline   Reply With Quote
Old 01-11-2012, 10:24 PM   #5
Ninja007
Board Member
 
Join Date: Mar 2009
Location: Lynnwood WA
Default

I had purchased the cable new from FCP. The bracket came from the donor car, a 940 I think, I will see if the bracket is the same since I still have my old bracket
Ninja007 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 06:49 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.