home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

Reply
 
Thread Tools Display Modes
Old 08-31-2022, 09:24 AM   #26
2 old for this
Board Member
 
Join Date: Mar 2018
Default

If you change the cam gear, DO NOT use a impact wrench to tighten the nut.
2 old for this is offline   Reply With Quote
Old 08-31-2022, 05:02 PM   #27
RR
Board Member
 
Join Date: May 2003
Location: Northern CA
Default

Quote:
Originally Posted by JohnMc View Post
Sure, but that gets into the variability of compression tests. It's going to crank faster with all the plugs out, which will tend to have slightly higher readings. But like I said, worry a bit less about the actual number, and just see if there pretty consistent across all 4. And after you do the 'dry' test, follow it up with a 'wet' test after putting in a teaspoon of oil.

Doing the valves is simple, takes about 15 unhurried minutes, and it's something that an old pushrod motor needs at periodic intervals. That and gapping the points and setting the timing.
Hello John, thanks for the help here; and you were right about valve adjustments...couple videos and your help got them adjusted and compression test performed.

Verdict, every valve was out of adjustment, no gap at all. Using the rule of nines, got them all back into .020 spec.

Compression check done on cold engine, carbs off and 3 other plugs in...

#1 was 150 psi
#2 was 142
#3 was 148 and
#4 was lower at 135

I am thinking that engine has no major issues and will move forward with rebuilt carbs, timing, etc.

How does the test sound to you, on a 142 with 400k miles?

Cheers, Rick
__________________
Mission District 1992 745 rescue~ rebuild
1994 940T Sedan
1970 142 S
2009 P71 Interceptor
1999 Suburban C2500

Last edited by RR; 08-31-2022 at 05:28 PM..
RR is offline   Reply With Quote
Old 09-06-2022, 03:39 PM   #28
142 guy
Board Member
 
142 guy's Avatar
 
Join Date: May 2014
Location: Saskatchewan, Canada
Default

Your average compression is 144 psi and your high / low numbers are within 10 psi which is super spectacular for a 400k engine unless it has already been rebuilt. Its a good thing that your compression tests are reasonable because if they weren't, your original budget of $1000 would be out the door.

Since you can crank the engine, I suggest that you hook up an oil pressure gauge to the port on the side of the block (where the oil pressure switch is) and measure your cranking oil pressure. No point in getting too far ahead with stuff if you can't generate reasonable oil pressure.

You had asked about parts vendors. The Volvo specialist vendors with the largest selection of 140 parts (that I have used) are
CVI - in Sweden
Scandcar - in Demark
Skandix - Germany
VP Autoparts - Sweden and US

I have used IPD and Iroll; but, IPD's selection of vintage parts is getting pretty small. Iroll is OK for parts that are shared with the 1800. High Performance Auto in Torrance CA has a lot of salvage parts when you can't find new and they can also access anything that VP has. If you need something that is out of production and High Performance can't find it, it is probably unobtanium. All of the preceding vendors have been reliable, unlike some others (beware VPD).

Rock Auto sells quite a few parts for the 140s at very good prices. They sell the aluminum Cloyes timing gear for a nice price.

When you checked the heads, did you inspect the rocker arm shoes (valve tip contact point)? At 400k they will almost certainly have grooves worn in them where they contact the valve tips making it impossible to set valve clearance accurately even with a narrow Vee tip feeler gauge inserted from the side. A machinist who has experience with vintage pushrod engines should be able to set up a jig and reprofile the shoes to eliminate the groove. I had all of them done on my B20E for about $40 - 10 years ago.

There was mention made of valvetrain wear. If your cam and lifters are original it is almost certain that there will be spalling on the contact surfaces requiring replacement of the cam and lifters. If you have a dial gauge you can check for this by measuring the valve lift on the valve spring retainer. The actual lift will vary with the cam in the engine; but, if there is significant variation in the lift you know that you have a cam / lifter wear issue.

If you are thinking about replacing the cam, the D cam is from the B20E. The D cam has a fair amount of duration with the result that if you try to idle around 800 RPM it idles with very poor vacuum. At 800 RPM the MAP on my MS2 equipped B20E with the D cam is around 60 kPa and the idle is a little erratic. SU carbs do not idle well with poor vacuum and you may need to crank up the idle speed close to 1000 RPM to get a smooth idle with a D cam. The F cam superseded the D cam. It has the same amount of lift; but, a nudge less duration. It will idle better with SU carbs and for regular driving you may find it has better performance because it has a slightly flatter torque curve. Tinus Tuning
https://www.tinustuning.nl/
grind some pretty nice cams; but, they are on the pricey side. You can email Ben at Tinus, tell him what you have and what you want and he will make some recommendations for you.

You mentioned ignition timing and 16 deg as a static timing setting. If that is 16 BTDC measured at the crankshaft there is no B20 engine that will tolerate that amount of static advance without generating a ping fest. A better starting point would be 10 deg BTDC and depending on the cam, octane rating of the fuel and compression ratio you may need to run less than that. I assume the reference to B20E was just for the distributor? If so, as has been mentioned the B20E distributor does have a negative vacuum advance. The distributor can be run just fine with straight mechanical advance with the vacuum retard port plugged. On an unknown engine I recommend that you disassemble and inspect the mechanical advance mechanism to make sure that the cam and the springs and weights move freely. For what it is worth, some vintages of the B20B engine also ran a distributor with a negative vacuum advance.
142 guy is offline   Reply With Quote
Old 09-12-2022, 10:56 AM   #29
RR
Board Member
 
Join Date: May 2003
Location: Northern CA
Default Thanks for the great info...

Quote:
Originally Posted by 142 guy View Post
Your average compression is 144 psi and your high / low numbers are within 10 psi which is super spectacular for a 400k engine unless it has already been rebuilt. Its a good thing that your compression tests are reasonable because if they weren't, your original budget of $1000 would be out the door.

Since you can crank the engine, I suggest that you hook up an oil pressure gauge to the port on the side of the block (where the oil pressure switch is) and measure your cranking oil pressure. No point in getting too far ahead with stuff if you can't generate reasonable oil pressure.

You had asked about parts vendors. The Volvo specialist vendors with the largest selection of 140 parts (that I have used) are
CVI - in Sweden
Scandcar - in Demark
Skandix - Germany
VP Autoparts - Sweden and US

I have used IPD and Iroll; but, IPD's selection of vintage parts is getting pretty small. Iroll is OK for parts that are shared with the 1800. High Performance Auto in Torrance CA has a lot of salvage parts when you can't find new and they can also access anything that VP has. If you need something that is out of production and High Performance can't find it, it is probably unobtanium. All of the preceding vendors have been reliable, unlike some others (beware VPD).

Rock Auto sells quite a few parts for the 140s at very good prices. They sell the aluminum Cloyes timing gear for a nice price.

When you checked the heads, did you inspect the rocker arm shoes (valve tip contact point)? At 400k they will almost certainly have grooves worn in them where they contact the valve tips making it impossible to set valve clearance accurately even with a narrow Vee tip feeler gauge inserted from the side. A machinist who has experience with vintage pushrod engines should be able to set up a jig and reprofile the shoes to eliminate the groove. I had all of them done on my B20E for about $40 - 10 years ago.

There was mention made of valvetrain wear. If your cam and lifters are original it is almost certain that there will be spalling on the contact surfaces requiring replacement of the cam and lifters. If you have a dial gauge you can check for this by measuring the valve lift on the valve spring retainer. The actual lift will vary with the cam in the engine; but, if there is significant variation in the lift you know that you have a cam / lifter wear issue.

If you are thinking about replacing the cam, the D cam is from the B20E. The D cam has a fair amount of duration with the result that if you try to idle around 800 RPM it idles with very poor vacuum. At 800 RPM the MAP on my MS2 equipped B20E with the D cam is around 60 kPa and the idle is a little erratic. SU carbs do not idle well with poor vacuum and you may need to crank up the idle speed close to 1000 RPM to get a smooth idle with a D cam. The F cam superseded the D cam. It has the same amount of lift; but, a nudge less duration. It will idle better with SU carbs and for regular driving you may find it has better performance because it has a slightly flatter torque curve. Tinus Tuning
https://www.tinustuning.nl/
grind some pretty nice cams; but, they are on the pricey side. You can email Ben at Tinus, tell him what you have and what you want and he will make some recommendations for you.

You mentioned ignition timing and 16 deg as a static timing setting. If that is 16 BTDC measured at the crankshaft there is no B20 engine that will tolerate that amount of static advance without generating a ping fest. A better starting point would be 10 deg BTDC and depending on the cam, octane rating of the fuel and compression ratio you may need to run less than that. I assume the reference to B20E was just for the distributor? If so, as has been mentioned the B20E distributor does have a negative vacuum advance. The distributor can be run just fine with straight mechanical advance with the vacuum retard port plugged. On an unknown engine I recommend that you disassemble and inspect the mechanical advance mechanism to make sure that the cam and the springs and weights move freely. For what it is worth, some vintages of the B20B engine also ran a distributor with a negative vacuum advance.
it is very helpful on this project...I have done several 240/740/940 rebuilds and this is my first 140 pushrod rebuild. I got the registration transferred here in CA, (lien sale, registration lapse...) so,
I am now considering pulling the engine and replacing camshaft, cam gears, lifters, rockers springs and machine the head.

I know I have shot my budget, but was making sure I could register before committing to the engine rebuild. I am also going to take the opportunity to lose the shifter slop, and clean up the engine bay, etc.

This decision came after yesterday's long attempt to restart the car, all new fluids, SU rebuilds, ignition attention, etc.

Off I go into 140 land!

Cheers and thanks again. Rick
RR is offline   Reply With Quote
Old 09-12-2022, 11:06 AM   #30
JohnMc
PV Abuser
 
JohnMc's Avatar
 
Join Date: May 2004
Location: St. Louis
Default

Absolutely no reason to pull the engine for that work. The heads come off very easily, maybe an hours work (well, stuck exhaust manifold nuts could be an issue, depending). And the cam comes out of the front with the engine in the car, remove the radiator and grille. They made sure on all the pushrod cars to make clearance for that, it works on PVs, 1800's, 122, 140's,

Of course, maybe you want to do other stuff while the motor is out of the car. Is it leaky around the oil pan? Any oil drips coming out of the bellhousing?
__________________
'63 PV Rat Rod
'93 245 16VT Classic #1141
JohnMc is offline   Reply With Quote
Old 09-12-2022, 11:12 AM   #31
RR
Board Member
 
Join Date: May 2003
Location: Northern CA
Default No oil leaks...

Quote:
Originally Posted by JohnMc View Post
Absolutely no reason to pull the engine for that work. The heads come off very easily, maybe an hours work (well, stuck exhaust manifold nuts could be an issue, depending). And the cam comes out of the front with the engine in the car, remove the radiator and grille. They made sure on all the pushrod cars to make clearance for that, it works on PVs, 1800's, 122, 140's,

Of course, maybe you want to do other stuff while the motor is out of the car. Is it leaky around the oil pan? Any oil drips coming out of the bellhousing?
out of the bellhousing or anywhere else I can see. I feel like the head work is going to happen, and a cam plus the cam gear which I believe to be my restart problem....

RR
RR is offline   Reply With Quote
Old 09-12-2022, 11:17 AM   #32
JohnMc
PV Abuser
 
JohnMc's Avatar
 
Join Date: May 2004
Location: St. Louis
Default

Did you ever get it started?

If you've got compression, then the cam gear and cam are working. About the only thing to look out for from that point are any valves with less lift than the others. Generally, cam lobes are fine until they get a little wear, then they wear down quickly. So really, what you're looking for are very obvious problems. WIth the valve cover off crank the motor over and eyeball each valve, one by one, if they all look like they go down roughly the same amount then you're good.
Or measure them if you like writing numbers down, but the chances are slim that you'd catch one in the extremely early stages.

Gas, spark (at the right time, ahem), and compression, all it needs to run.
JohnMc is offline   Reply With Quote
Old 09-12-2022, 11:25 AM   #33
RR
Board Member
 
Join Date: May 2003
Location: Northern CA
Default Well...

Quote:
Originally Posted by JohnMc View Post
Did you ever get it started?

If you've got compression, then the cam gear and cam are working. About the only thing to look out for from that point are any valves with less lift than the others. Generally, cam lobes are fine until they get a little wear, then they wear down quickly. So really, what you're looking for are very obvious problems. WIth the valve cover off crank the motor over and eyeball each valve, one by one, if they all look like they go down roughly the same amount then you're good.
Or measure them if you like writing numbers down, but the chances are slim that you'd catch one in the extremely early stages.

Gas, spark (at the right time, ahem), and compression, all it needs to run.
When I started adjusting the valves, there was no clearance at all. I adjusted them all to spec.

The timing has been addressed, though found out I have a b20E distributor cap on my B20B; but believe after plenty of rereading, and fiddling, have the timing correct.

Fuel delivery may be an issue, though I did drain the old gas out and SU's rebuilt on east coast. I may still have some SU learning to do.

Thinking the valve and headwork is mandatory...this car is straight and rust free.

Thanks again John.
RR is offline   Reply With Quote
Old 09-12-2022, 11:50 AM   #34
RR
Board Member
 
Join Date: May 2003
Location: Northern CA
Default Noted,

Quote:
Originally Posted by dl242gt View Post
On a high mileage pushrod engine. I'd want to inspect the cam gear for wear as that can catastrophically fail and leave you stranded. You can get a basic idea of the wear by slightly turning the motor over and watching the distributor. You can rock the crank back and forth slightly to see how far it moves before it moves the distributor. If it's a lot of slack then the cam gear is worn.
thanks again.
RR is offline   Reply With Quote
Old 09-12-2022, 12:24 PM   #35
142 guy
Board Member
 
142 guy's Avatar
 
Join Date: May 2014
Location: Saskatchewan, Canada
Default

Quote:
Originally Posted by RR View Post
I know I have shot my budget, but was making sure I could register before committing to the engine rebuild. I am also going to take the opportunity to lose the shifter slop, and clean up the engine bay, etc.
Two sources of shifter slop on the original style long swan neck shifter. One sort of easy to fix, the other more involved.

The technically easy to fix problem is deterioration of the two rubber bushings inside the shift lever. If you can easily twirl the shift lever knob those bushings are almost certainly history. Easy to replace (just yank the shift lever outer chrome part off); but, the bushings are / were out of production. Contact Hi Performance Auto in Torrance CA. They were making Poly reproductions. That is where I got mine.

The other slop point is wear in the shift lever pivot points in the top cover. You can find threads on different Volvo forums describing the repair. You essentially have to find bushings to fit over the two pivot pins on the shift lever and then grind out the slots on the top cover opening to accept the larger bushings.

Check the rubber bushings first because it is a more common problem than the worn pivots.
142 guy is offline   Reply With Quote
Old 09-12-2022, 03:46 PM   #36
RR
Board Member
 
Join Date: May 2003
Location: Northern CA
Default Thanks again

Quote:
Originally Posted by 142 guy View Post
Two sources of shifter slop on the original style long swan neck shifter. One sort of easy to fix, the other more involved.

The technically easy to fix problem is deterioration of the two rubber bushings inside the shift lever. If you can easily twirl the shift lever knob those bushings are almost certainly history. Easy to replace (just yank the shift lever outer chrome part off); but, the bushings are / were out of production. Contact Hi Performance Auto in Torrance CA. They were making Poly reproductions. That is where I got mine.

The other slop point is wear in the shift lever pivot points in the top cover. You can find threads on different Volvo forums describing the repair. You essentially have to find bushings to fit over the two pivot pins on the shift lever and then grind out the slots on the top cover opening to accept the larger bushings.

Check the rubber bushings first because it is a more common problem than the worn pivots.
for your help here. Rick
RR is offline   Reply With Quote
Old 09-12-2022, 09:10 PM   #37
spock345
Board Member
 
spock345's Avatar
 
Join Date: Nov 2016
Location: Livermore, CA
Default

Quote:
Originally Posted by 142 guy View Post
Two sources of shifter slop on the original style long swan neck shifter. One sort of easy to fix, the other more involved.

The technically easy to fix problem is deterioration of the two rubber bushings inside the shift lever. If you can easily twirl the shift lever knob those bushings are almost certainly history. Easy to replace (just yank the shift lever outer chrome part off); but, the bushings are / were out of production. Contact Hi Performance Auto in Torrance CA. They were making Poly reproductions. That is where I got mine.

The other slop point is wear in the shift lever pivot points in the top cover. You can find threads on different Volvo forums describing the repair. You essentially have to find bushings to fit over the two pivot pins on the shift lever and then grind out the slots on the top cover opening to accept the larger bushings.

Check the rubber bushings first because it is a more common problem than the worn pivots.
That said pretty much every M40 top cover I've seen is somewhat worn.
__________________
1967 122s, carbed B20F, M41, the sports tractor
1998 S70, grandma-mobile
1980 245
1989 240 B230F, V15 cam, chipped EZK, M47 swap (Lost a fight with a Chevy express van), the millennial falcon
2012 VW Tiguan (screw plastic water pumps), daily
spock345 is offline   Reply With Quote
Old 09-15-2022, 07:21 AM   #38
c1800
Board Member
 
Join Date: Jun 2014
Location: A small village of one.
Default

Quote:
Originally Posted by RR View Post
When I started adjusting the valves, there was no clearance at all. I adjusted them all to spec.

The timing has been addressed, though found out I have a b20E distributor cap on my B20B; but believe after plenty of rereading, and fiddling, have the timing correct.

Fuel delivery may be an issue, though I did drain the old gas out and SU's rebuilt on east coast. I may still have some SU learning to do.

Thinking the valve and headwork is mandatory...this car is straight and rust free.

Thanks again John.
Don’t all B20 engines use the same distributor cap?
c1800 is offline   Reply With Quote
Old 09-15-2022, 08:58 AM   #39
RR
Board Member
 
Join Date: May 2003
Location: Northern CA
Default Well, yes...

Quote:
Originally Posted by c1800 View Post
Don’t all B20 engines use the same distributor cap?
and no. My B20B replacement cap had a recessed alignment notch, instead of a protruding alignment notch; aligning cap with distributor. I found this out after ordering what I thought was the correct cap, but no...IPD dude said part number I gave him from the old cap was proper for 1974 B20E...go figure.

Lesson I learned was that this car, like many older cars may have been fitted with cobbled parts.

Cheers
RR is offline   Reply With Quote
Old 09-15-2022, 09:57 AM   #40
spock345
Board Member
 
spock345's Avatar
 
Join Date: Nov 2016
Location: Livermore, CA
Default

Quote:
Originally Posted by RR View Post
and no. My B20B replacement cap had a recessed alignment notch, instead of a protruding alignment notch; aligning cap with distributor. I found this out after ordering what I thought was the correct cap, but no...IPD dude said part number I gave him from the old cap was proper for 1974 B20E...go figure.

Lesson I learned was that this car, like many older cars may have been fitted with cobbled parts.

Cheers
Yeah, given that rebuild parts for those distributors are hard to come by most folks just use whatever they can. Also I've noticed a difference between caps that have the clip surfaces slightly rotated with respect to the wire connections and those that don't. I made the mistake of ordering the wrong cap that way once.
spock345 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 07:05 AM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.