home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > maintenance & nonperformance

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 03-31-2021, 04:23 PM   #1
fatcatbestcat
Professional Hack
 
fatcatbestcat's Avatar
 
Join Date: Oct 2019
Location: Mississauga, ON (Canada)
Default 140 Linkage Solutions?

Right, this isn't a problem yet, but I can see it being an issue in the future, so I figure I might as well ask and order parts now.

So I have a 1967 144S, which originally came with SU carbs. I'm probably swapping to either a 38/38 DGMS or DCOE 45s when I get around to reassembling the (swapped) engine.

I understand that the 140s, because of the intake being on the passenger side, has a linkage bar of some sort that runs under the dash.



Where exactly am I supposed to attach any kind of aftermarket linkage arms to?

I see this nub that pokes out of the firewall, but is it threaded?

I also happen to have an IPD throttle cable conversion kit for a DGMS... is that possible to use on a non-EFI car?

Sorry for some probably dumb noob questions.
Any guidance is helpful.
__________________
Doing the wrong thing the right way.

-------------------------------------------

Quote:
Originally Posted by redblockpowered View Post
Will you do $14.99 shipped?
Quote:
Originally Posted by IansPlatinum View Post
please no more prying things with screwdrivers and bashing things with hammers!
Quote:
Originally Posted by Cwazywazy View Post
my balls have more wrinkles than my brain
--------------------------------------------

-1967 144S
-1983 245 Diesel
fatcatbestcat is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 11:20 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.