home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

Reply
 
Thread Tools Display Modes
Old 06-21-2021, 12:02 AM   #201
cosbySweater
Board Member
 
cosbySweater's Avatar
 
Join Date: Jul 2009
Location: Monterey/Falun
Default

Quote:
Originally Posted by Jerd View Post
No change was made when I installed an aem in the tank for a main pump and ran new fuel line to the the filter area and replaced the filter. I'll see if I can use a loaner from costless or somewhere to check the pressure.
My kjet car did that for a super long time and I never was able to pinpoint it before I ls swapped the car :/ wish I could be more help for you
__________________
1974 AMC Gremlin, lq4, 7875 billet, ss2 cam, 80e, 3600 stall converter, Holley Terminator x
1984 Volvo 245 Om606td, 722.6, Lifted
1995 Porsche 993
2013 VW Passat TDI
Quote:
Originally Posted by bricktop420 View Post
Thank you very much everybody... i now feel sufficiently retarded and will go cry in the corner...
cosbySweater is offline   Reply With Quote
Old 06-21-2021, 11:43 AM   #202
Jerd
Board Member
 
Jerd's Avatar
 
Join Date: Mar 2008
Location: Vancouver WA
Default

Quote:
Originally Posted by cosbySweater View Post
My kjet car did that for a super long time and I never was able to pinpoint it before I ls swapped the car :/ wish I could be more help for you
It's fine. I searched on here and other forums and found several very similar threads, most were unresolved.

I feel like I have tried most of the logical stuff and since I plan on going standalone anyways I'm pretty much done spending time and money to try and resolve this one myself. With that being said, if anyone reading this has any other ideas, I'm all ears.
Jerd is offline   Reply With Quote
Old 08-02-2021, 11:40 AM   #203
Jerd
Board Member
 
Jerd's Avatar
 
Join Date: Mar 2008
Location: Vancouver WA
Default

Did some glambling, car held up great i didn't run into any drivetrain issues. The Bilstein HDs are hurting, both sides have gotten pretty sticky, not sure if it was the fine dust or if i got them too hot. The day we drove home was about 114* and the clutch fan seemed to be doing its job because the car didn't overheat once. The car performed well, the only thing that bothered me was the under damped rebound in the rear. I think a slightly stiffer spring rate could also be beneficial but its hard to tell when the damping is all wrong.


Added a bulkhead to the fuel sender instead of running a reducing hose barb and hose clamps.



Swapped the B cam out for an IPD turbo cam, and then turned the boost up. I bought some LH chips but im still working out some kinks with the guy that burns them, i have either got two bad chips or there is some compatability issues with my ecu.



The car is super fun to rip around in at ~14psi. It pings a little at 15psi with boost onset, hopefully the fuel chip will help with that when I can get it working. This car puts a smile on my face almost every time i drive it, if i can get it running a reliable 15psi i think ill call it good for power mods and focus on suspension. Its pretty dang quick on the street and its more than enough on dirt.

Last edited by Jerd; 08-02-2021 at 03:33 PM..
Jerd is offline   Reply With Quote
Old 08-02-2021, 12:15 PM   #204
Harlard
Hurlurd?Harland?Bueller?
 
Harlard's Avatar
 
Join Date: May 2007
Location: PDX
Default

__________________


Herr Harlard am Erstens

1979 242 DL

Quote:
Originally Posted by t8fanning View Post
My knob has a big chunk of steel on it
Harlard is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 09:46 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.