home register FAQ memberlist calendar

Go Back   Turbobricks Forums > Mechanical > projects & restorations

Reply
 
Thread Tools Display Modes
Old 09-08-2021, 04:33 AM   #1
Mr.Borrie
The Sneaky F*ing Russian
 
Mr.Borrie's Avatar
 
Join Date: Aug 2006
Location: Netherlands
Default SC-900 Radio swap C70

Hi There,

I have read allot of thing on the radio wiring of the Volvo C70 03 with a SC-900.
This system has a separate amp so a direct radio swap is not possible.

There are some DIN to RCA adapters that would allow you to power the speakers via aftermarket system. However this does not have the connector for " main sub" as one of the connector on the back of the SC-900 is called.

Adapter: https://www.amazon.nl/Actief-systeem.../dp/B00WJRMKK0

I assume i will loose the sub if that wire will get disconnected..?

I am starting to think to just send back the pioneer-sph-da230dab

Also intresting post: https://www.matthewsvolvosite.com/fo...ic.php?t=30204
https://www.matthewsvolvosite.com/fo...ic.php?t=81981





EDIT:

I Guess all will just work with that adapter, i ordered it and will report back
__________________
760 Turbo 86|Volvo 360 cup|Volvo XC90 04|Volvo C70 C 03|Volvo 745 turbo 86|Porsche 924 79|

My Seller Feedback

Last edited by Mr.Borrie; 09-08-2021 at 07:59 AM..
Mr.Borrie is offline   Reply With Quote
Old 09-10-2021, 06:01 AM   #2
reiernumans
Board Member
 
Join Date: Jan 2014
Default

If that 6 pin DIN connector powers all the speakers in the car including the sub, it should work perfectly.

I make/sell something similar for older Saabs that use an 8 pin DIN connector on the amp that powers the doorspeakers. It's nice being able to hook into a decent quality OEM amp/speaker system. Often they work great, whereas cars with aftermarket speakers usually sound mweh unless someone who knows what they're doing has figured that whole system out, haha.
reiernumans is offline   Reply With Quote
Old 09-10-2021, 01:50 PM   #3
Mr.Borrie
The Sneaky F*ing Russian
 
Mr.Borrie's Avatar
 
Join Date: Aug 2006
Location: Netherlands
Default

Got the adapter in, works!

Last edited by Mr.Borrie; 09-10-2021 at 01:58 PM..
Mr.Borrie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump


All times are GMT -4. The time now is 04:06 PM.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.